数据结构实验之串二:字符串匹配
Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^
题目描述
给定两个字符串string1和string2,判断string2是否为string1的子串。
输入
输入包含多组数据,每组测试数据包含两行,第一行代表string1,第二行代表string2,string1和string2中保证不出现空格。(string1和string2大小不超过100字符)
输出
对于每组输入数据,若string2是string1的子串,则输出"YES",否则输出"NO"。
示例输入
abc a 123456 45 abc ddd
示例输出
YES YES NO
#include <iostream>
#include <string.h>#include <stdlib.h>
#include <stdio.h>
using namespace std;
int next[1000001];
char S1[1000001],S2[1000001];
int KMP(char a[],char b[],int l1,int l2)
{
int i=0,j=0;
while(i<l1&&j<l2)
{
if(j==-1||a[i]==b[j])
{
++i;
++j;
}
else j=next[j];
}
if(j>=l2) return i-l2+1;
else return -1;
}
void Next(char c[],int l2)
{
int i=0,j=-1;
next[0]=-1;
while(i<l2)
{
if(j==-1||c[i]==c[j])
{
i++;
j++;
next[i]=j;
}
else j=next[j];
}
}
int main()
{
int len1,len2,k;
while(cin>>S1>>S2)
{
len1=strlen(S1);
len2=strlen(S2);
Next(S2,len2);
k=KMP(S1,S2,len1,len2);
if(k==-1)
cout<<"NO"<<endl;
else cout<<"YES"<<endl;
}
}