wampserver 多个PHP版本配置后,无法启动

网上很多wampserver 多个PHP 版本配置的方法

如果配置好后,无法启动,可以借助 事件查看器,来查看出错的原因


根据提示,逐个排查

另外要注意apache 支持的PHP 的版本


1、Apache2.0对应的PHP模块为 php5apache2.dll

2、Apache2.2对应的PHP模块为 php5apache2_2.dll

3、Apache2.4对应的PHP模块为 php5apache2_4.dll

换句话说,根据php5_module模块,可以知道当前版本php支持哪种Apache

所以,Apache/PHP的搭配有以下几种情况:

1、php5.2支持Apache2.0和Apache2.2;

2、php5.3、php5.4同时支持Apache2.2和Apache2.4;

3、php5.5只支持Apache2.4

除非你自己手动编译php5_module模块,否则只能有以上3种选择。




阅读更多

没有更多推荐了,返回首页