LightOJ - 1030 Discovering Gold 期望 DP

4 篇文章 0 订阅
2 篇文章 0 订阅

You are in a cave, a long cave! The cave can be represented by a 1 x N grid. Each cell of the cave can contain any amount of gold.

Initially you are in position 1. Now each turn you throw a perfect 6 sided dice. If you get X in the dice after throwing, you add X to your position and collect all the gold from the new position. If your new position is outside the cave, then you keep throwing again until you get a suitable result. When you reach the Nth position you stop your journey. Now you are given the information about the cave, you have to find out the expected number of gold you can collect using the given procedure.

Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer N (1 ≤ N ≤ 100) denoting the dimension of the cave. The next line contains N space separated integers. The ith integer of this line denotes the amount of gold you will get if you come to the ith cell. You may safely assume that all the given integers will be non-negative and no integer will be greater than 1000.

Output
For each case, print the case number and the expected number of gold you will collect. Errors less than 10-6 will be ignored.

Sample Input
3
1
101
2
10 3
3
3 6 9
Sample Output
Case 1: 101.0000000000
Case 2: 13.000
Case 3: 15

题意:1×n的格子,每到一个格子就可以拿走这个格子内的全部金子,起始位置在第1个格子,然后开始掷骰子,得到点数x,就从当前位置走到加x的位置,如果位置是大于n就重新掷骰子直到符合,如果到了第n个格子就结束。问得到的金子的期望是多少。

题解:
(期望DP)正向推概率,反向推期望
从后往前推
最后一步必须走到n位置,所以需要判断上一步的位置是否已经超过了n

#include <iostream>
#include <cstdio>
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N = 106;

double v[N], f[N];

int main()
{
	int t, n, i, cas = 0;
	scanf("%d", &t);
	while(t--){
		memset(f, 0, sizeof f);
		scanf("%d", &n);
		for(i = 1; i <= n; ++i){
			scanf("%lf", &v[i]);
		}
		f[n] = v[n];
		for(i = n-1; i > 0; --i){
			for(int j = 1; j <= 6; ++j){
				double len = min(6, n-i);
				f[i] += f[i+j]*1.0/len;
			}
			f[i] += v[i];
		}
		printf("Case %d: %lf\n", ++cas, f[1]);
	}
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值