hdu1045

Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4197    Accepted Submission(s): 2391


Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 
 

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file. 
 

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

Sample Input
  
  
4 .X.. .... XX.. .... 2 XX .X 3 .X. X.X .X. 3 ... .XX .XX 4 .... .... .... .... 0
 

Sample Output
  
  
5 1 5 2 4


题意:给定一个地图,‘.’的位置可以放置大炮,‘X’位置可以阻止大炮相互攻击,问给定地图最多可以放置多少个大炮。

思路:从左上角第一个开始枚举,由于当前的摆放会影响后面的摆放,所以总的可能性非常少,而n最多等于4所以不会超时(实际我用了0ms)。枚举顺序为从左到右从上到下,每个格子编号从0到n^2 - 1,而每个格子的坐标恰好就是(number/n,number%n)。row[],cow[]分别标记当前行和当前列是否可以放置大炮。当前位置可以放置大炮的条件是:1、图案是‘.’;2、当前行可以摆放;3、当前列可以摆放。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
char Mp[4][4];
bool row[4],cow[4];
int ans ,n,tn;
void dfs(int num,int cnt)
{
    if(num == tn){
        ans = max(ans,cnt);
        return;
    }
    int x = num/n,y = num%n;
    if(Mp[x][y] == 'X')
    {
       row[x] = false;
       cow[y] = false;
        dfs(num + 1,cnt);//当前不可以摆放就继续下一个位置的枚举
    }
    else
    {		//在可以摆放的位置枚举摆放和不摆放的情况
        if(!row[x] && !cow[y])//摆放
        {
            row[x] = true;
            cow[y] = true;	//放了以后标记不可以摆放
            dfs(num + 1,cnt + 1);
            row[x] = false;	//还原标记
            cow[y] = false;
        }
        dfs(num + 1,cnt);	//当前位置不摆放

    }
}
int main()
{

    while(~scanf("%d", &n) && n)
    {
        ans = 0;
        for(int i = 0;i < n;i ++)
            scanf("%s",Mp[i]);
        memset(row,0,sizeof(row));
        memset(cow,0,sizeof(cow));
        tn = n*n;
        dfs(0,0);
       printf("%d\n",ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值