hdu1227

12 篇文章 0 订阅

 

Fast Food

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1514    Accepted Submission(s): 658


Problem Description
The fastfood chain McBurger owns several restaurants along a highway. Recently, they have decided to build several depots along the highway, each one located at a restaurant and supplying several of the restaurants with the needed ingredients. Naturally, these depots should be placed so that the average distance between a restaurant and its assigned depot is minimized. You are to write a program that computes the optimal positions and assignments of the depots.

To make this more precise, the management of McBurger has issued the following specification: You will be given the positions of n restaurants along the highway as n integers d1 < d2 < ... < dn (these are the distances measured from the company's headquarter, which happens to be at the same highway). Furthermore, a number k (k <= n) will be given, the number of depots to be built.

The k depots will be built at the locations of k different restaurants. Each restaurant will be assigned to the closest depot, from which it will then receive its supplies. To minimize shipping costs, the total distance sum, defined as



must be as small as possible.

Write a program that computes the positions of the k depots, such that the total distance sum is minimized.
 

Input
The input file contains several descriptions of fastfood chains. Each description starts with a line containing the two integers n and k. n and k will satisfy 1 <= n <= 200, 1 <= k <= 30, k <= n. Following this will n lines containing one integer each, giving the positions di of the restaurants, ordered increasingly.

The input file will end with a case starting with n = k = 0. This case should not be processed.
 

Output
For each chain, first output the number of the chain. Then output a line containing the total distance sum.

Output a blank line after each test case.
 

Sample Input
      
      
6 3 5 6 12 19 20 27
0 0 
Sample Output
      
      
Chain 1 Total distance sum = 8
 

这个题目是个痛苦的经历。。。。。

定义状态:dp[i][j]为前j个餐厅,建立i个供应站的最短距离。dp[i][j] = min(dp[i][j],dp[i - 1][k - 1] + cost[k][j]) 动态规划阶段决策,就是在前k- 1个(k >= j)餐厅,建立i - 1个供应站距离的最短基础上再加一个供应站和一个餐厅,所得到的新状态,cost[k ][j]就是指第k个供应站摆到第k到第j个餐厅所得到的最短距离,取中位数最小(据说有证明)。为什么不是直接把dp[i - 1][k - 1]换成dp[i - 1][j - 1],这样看起来更像(我开始就这么疑惑,不懂dp)。那是因为,新加入了一个餐厅,那么改变供应站的分配位置,就可能得到更优的值,所以需要一个一个比较。我又疑惑,动态规划本来是提高速度的,这样像搜索,到底哪里减少了废状态呢?如果暴力的话。。。。从第一位开始,选,或不选(如果不选的话剩下的位子不够放k个就必须选),而动态规划在尝试的时候每次尝试只是更一种方法比较,早已经被淘汰的方法不再比较这就删除了很多种状态,使得生成的状态大大减少。。。。。。这些我写给自己看的,估计很多人都懂。

#include<algorithm>
#include <cstring>
#include<cstdio>
#include<math.h>
typedef long long ll;
using namespace std;
int dp[33][222];
int dis[222],cost[222][222];
int main()
{
    int n , m, I = 0;
    while(scanf("%d%d",&n, &m))
    {
        if(n == 0 && m == 0)break;
        for(int i = 1;i <= n;i ++)
            scanf("%d",dis + i);

       memset(cost,0,sizeof(cost));
          for(int i = 1;i <= n;i ++)
            for(int j = i;j <= n;j ++)
            {
                int mi = (j + i) >> 1;
                for(int k = i;k <= j;k ++)
                cost[i][j] += abs(dis[mi] - dis[k]);//预处理
            }

       memset(dp,1,sizeof(dp));//赋值无穷大
        dp[0][0] = 0;//合法状态大小0
       for(int i = 1;i <= m;i ++)
            for(int j = i;j <= n;j ++)//如果供应站多于餐厅显然不对,所以从等于的地方开始
             for(int k = i;k <= j;k ++)
                     dp[i][j] = min(dp[i][j],dp[i - 1][k - 1] + cost[k][j]);


        printf("Chain %d\nTotal distance sum = %d\n\n",++I,dp[m][n]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值