poj1001 + 高精度的心得

Japan
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16970 Accepted: 4552

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5



这个题在了解了高精度乘法后将是一题很水的题目。先说一下高精度,之前非常不喜欢高精度的题目。原因是简单的题目实现,加上简单的高精度,结合起来感觉很麻烦。一个简单的递推,加上高精度就感觉不会了。直到我看到了师兄写的高精度。那是运用了面向对象的思想,把高精度的运算全都封装在了BigInt这个结构体类型里面了,这样普通递推公式的修改只需要改一下定义类型,其它什么都不需要改。这种代码看起来也舒服,之前看到网上的高精度都是各种函数实现,看得非常痛苦。


#include<cstdio>
#include<cstring>
#include<queue>
#include<stack>
#include<map>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<iostream>
#define rep(i,a) for(int i = 0;i < a;i ++)
using namespace std;
const int N = 500010;
struct BigDouble
{
	int num[333];
	int len;
	BigDouble(char s[],int len){
		this->len = len;
		//strrev(s);这个函数不是标准c++函数不能用,poj不认识>_<
		int L = strlen(s);
		for(int i = 0;i <= L - i - 1;i ++)
			swap(s[i],s[L - i - 1]);
		for(int i = 0;s[i] != '\0';i ++)
		num[i] = s[i] - '0';
	}
	BigDouble(){
		len = 1;
		memset(num,0,sizeof(num));
	}
	void setOne(){
		memset(num,0,sizeof(num));
		num[0] = 1;
		len = 1;
	}
	friend BigDouble operator*(BigDouble a,BigDouble b)//重载乘法运算
	{
		BigDouble res;
		for(int i = 0;i < a.len;i ++)
		{
			for(int j = 0;j < b.len;j ++)
			{
				res.num[i + j] += a.num[i] * b.num[j];
				res.num[i + j + 1] += res.num[i + j]/10;
				res.num[i + j]%= 10;
			}
		}
		for(int i = 300;i >= 0;i --){
			if(res.num[i] != 0){
				res.len = i + 1;
				break;
			}
		}
		return res;
	}
	void print()//这个是给普通大数打印用的方法
	{
		int s = len - 1;
		for(;s >= 0;s --)printf("%d",num[s]);
			puts("");
	}
};
int main(){
	char num[333];
	int n;
	while(cin >> num >> n)
	{
		bool point = false;//记录是否存在小数点
		int local = 0;//小数点位置
		for(int i = 0;num[i] != '\0';i ++)
		{
			if(num[i] == '.'){
				point = true;
				local = i;
				break;
			}
		}

		int l = strlen(num);
		for(int i = l- 1;i > local;i --)
			if(num[i] == '0')l--;
		else break;

		if(point){//在有小数点的情况下转换为整数
		for(int i = local;i < l;i ++)
			num[i] = num[i + 1];
		l--;num[l] = '\0';
		local = l - local;
		local *= n;//得到最终的小数位数,local等于0就没有小数位数
		}
		
		
		
		BigDouble res;
		res.num[0] = 1;
		BigDouble tmp(num,l);//初始化大整数类型,相当于调用有参的构造方法
		
		for(int i = 1;i <= n;i ++)
			res = res*tmp;

		int s = res.len - 1;
		
		if(point){//输出小数点后面的前导零
			local = res.len - local;
			if(local < 0)printf(".");
			while(local < 0){
			    printf("0");local++;
			}
		}
		
		for(int j = 1;s >= 0;s --,j ++)
		{
			printf("%d",res.num[s]);
			if(j == local && s)printf(".");
		}
		puts("");//回车
	}
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值