PAT(天梯赛练习题) -L2-009. 抢红包

题目链接

没有人没抢过红包吧…… 这里给出N个人之间互相发红包、抢红包的记录,请你统计一下他们抢红包的收获。

输入格式:

输入第一行给出一个正整数N(<= 104),即参与发红包和抢红包的总人数,则这些人从1到N编号。随后N行,第i行给出编号为i的人发红包的记录,格式如下:

K N1 P1 ... NK PK

其中K(0 <= K <= 20)是发出去的红包个数,Ni是抢到红包的人的编号,Pi(> 0)是其抢到的红包金额(以分为单位)。注意:对于同一个人发出的红包,每人最多只能抢1次,不能重复抢。

输出格式:

按照收入金额从高到低的递减顺序输出每个人的编号和收入金额(以元为单位,输出小数点后2位)。每个人的信息占一行,两数字间有1个空格。如果收入金额有并列,则按抢到红包的个数递减输出;如果还有并列,则按个人编号递增输出。

输入样例:
10
3 2 22 10 58 8 125
5 1 345 3 211 5 233 7 13 8 101
1 7 8800
2 1 1000 2 1000
2 4 250 10 320
6 5 11 9 22 8 33 7 44 10 55 4 2
1 3 8800
2 1 23 2 123
1 8 250
4 2 121 4 516 7 112 9 10
输出样例:
1 11.63
2 3.63
8 3.63
3 2.11
7 1.69
6 -1.67
9 -2.18
10 -3.26
5 -3.26
4 -12.32

也没什么好说的,结构体排序吧。注意一下优先级就好了(应该没卡精度吧?)。

#include<iostream>
#include<string>
#include<cstring>
#include<vector>
#include<map>
#include<algorithm>
#include<queue>
#include<set>
#include<cstdio>
#include<functional>
#include<iomanip>
#include<cmath>
#include<stack>
#define eps 1e-6
#define inf 0x7fffffff
const int maxn = (int)1e4 + 100;
const int mod = (int)1e9;
const int seed = 31;
using namespace std;
typedef long long LL;
typedef unsigned long long ull;
struct nodes {
  int num, mon, cu;
  bool operator <(const nodes &a)const {
    if (mon == a.mon) {
      if (cu==a.cu) return num < a.num;
      return cu > a.cu;
    }
    return mon > a.mon;
  }
}a[maxn];
int main() {
  //freopen("D:\\cpp\\test.txt", "r", stdin);  
  int n;
  scanf("%d", &n);
  for (int i = 1; i <= n; i++) {
    a[i].num = i;
    a[i].cu = 0;
    a[i].mon = 0;
  }
  int k, x, y;
  for (int i = 1; i <= n; i++) {
    scanf("%d", &k);
    for (int j = 0; j < k; j++) {
      scanf("%d%d", &x, &y);
      a[x].mon += y;
      a[x].cu++;
      a[i].mon -= y;
    }
  }
  sort(a+1, a + n+1);
  for (int i = 1; i <= n; i++) {
    printf("%d %.2lf\n", a[i].num, double(a[i].mon) / 100);
  }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值