7-2 银行业务队列简单模拟 (25 分)

设某银行有A、B两个业务窗口,且处理业务的速度不一样,其中A窗口处理速度是B窗口的2倍 —— 即当A窗口每处理完2个顾客时,B窗口处理完1个顾客。给定到达银行的顾客序列,请按业务完成的顺序输出顾客序列。假定不考虑顾客先后到达的时间间隔,并且当不同窗口同时处理完2个顾客时,A窗口顾客优先输出。

输入格式:

输入为一行正整数,其中第1个数字N(≤1000)为顾客总数,后面跟着N位顾客的编号。编号为奇数的顾客需要到A窗口办理业务,为偶数的顾客则去B窗口。数字间以空格分隔。

输出格式:

按业务处理完成的顺序输出顾客的编号。数字间以空格分隔,但最后一个编号后不能有多余的空格。

输入样例:

8 2 1 3 9 4 11 13 15
输出样例:

1 3 2 9 11 4 13 15

#include<stdio.h>
#include<stdlib.h>
struct queue {
    int Data[1000];
    int Rear;  
    int Front; 
};
void Addqueue(struct queue *q, int x); 
int Deletequeue(struct queue *q);
void Createqueue(struct queue *q);
int Isqueue(struct queue *q) ;
int main(void)
{
    struct queue A,B;
    Createqueue(&A);
    Createqueue(&B);
    int i, n, x;
    scanf("%d", &n);
    for(i = 0; i < n; i ++) {
        scanf("%d", &x);
        if(x % 2 != 0) {
            Addqueue(&A, x);
        }
        else {
            Addqueue(&B, x);
        }
    }
    i = 0;
    while(Isqueue(&A) || Isqueue(&B)) {
        if(Isqueue(&A)) {
            if(i == 0) {
                printf("%d", Deletequeue(&A));
                i ++;
            }
            else {
                printf(" %d", Deletequeue(&A));
            }   
        }
        if(Isqueue(&A)) {
            printf(" %d", Deletequeue(&A));
        }
        if(Isqueue(&B)) {
            if(i == 0) {
                printf("%d", Deletequeue(&B));
                i ++; 
            }
            else {
                printf(" %d", Deletequeue(&B));
            }
        }
    }
    return 0;
}
void Addqueue(struct queue *q, int x) 
{
    q-> Rear++;
    q->Data[q->Rear] = x;
}
int Deletequeue(struct queue *q) 
{
    q->Front ++;
    return q->Data[q->Front];
}
void Createqueue(struct queue *q)
{
    q->Rear = -1;
    q->Front = -1;
}
int Isqueue(struct queue *q) 
{
    int i;
    if(q->Rear == q->Front) {
        i = 0;
    }
    else {
        i = 1;
    }
    return i;
} 
  • 2
    点赞
  • 14
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值