CSU-ACM2017暑假集训比赛2 A - _(:з」∠)_

A - _(:з」∠)_

 There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?

Input

The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.

Output

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

Sample Input

5 1 5
3 3 1 2 5
0

Sample Output

3

题目较易,就是对不同按键情况下的楼层变化情况进行BFS,留意下一步的位置:并非常见的跳转至数组元素所显示的位置;当前位置加减这个元素所得到的值才是下一位置。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <queue>
#include <cstring>
using namespace std;

int n, a, b, k[205], minStep;
bool isAccessed[205];

struct status{
    int now, step;
    status(){}
    status(int a, int c):now(a),step(c){}
};

void bfs(){
    queue<status> q;
    q.push(status(a,0));
    while(!q.empty()){
        status temp = q.front();
        q.pop();
        if(temp.now == b){
            minStep = temp.step;
            return;
        }
        int now = temp.now, step = temp.step, next = k[now];
        isAccessed[now] = true;
        if(!isAccessed[now+next])
            if(now + next <= n)
                q.push(status(now+k[now], step+1));
        if(!isAccessed[now-next])
            if(now - next >= 1)
                q.push(status(now-k[now], step+1));
    }
}

int main(){
#ifdef TEST
freopen("test.txt", "r", stdin);
#endif // TEST

    while(cin >> n){
        if(n == 0)
            break;
        cin >> a >> b;
        minStep = -1;
        memset(isAccessed, false, sizeof(isAccessed));
        for(int i = 1; i<=n; i++)
            cin >> k[i];
        bfs();
        cout << minStep << endl;
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值