hdu4455(DP)

Substrings

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 968    Accepted Submission(s): 283


Problem Description
XXX has an array of length n. XXX wants to know that, for a given w, what is the sum of the distinct elements’ number in all substrings of length w. For example, the array is { 1 1 2 3 4 4 5 } When w = 3, there are five substrings of length 3. They are (1,1,2),(1,2,3),(2,3,4),(3,4,4),(4,4,5)
The distinct elements’ number of those five substrings are 2,3,3,2,2.
So the sum of the distinct elements’ number should be 2+3+3+2+2 = 12
 

Input
There are several test cases.
Each test case starts with a positive integer n, the array length. The next line consists of n integers a 1,a 2…a n, representing the elements of the array.
Then there is a line with an integer Q, the number of queries. At last Q lines follow, each contains one integer w, the substring length of query. The input data ends with n = 0 For all cases, 0<w<=n<=10 6, 0<=Q<=10 4, 0<= a 1,a 2…a n <=10 6
 

Output
For each test case, your program should output exactly Q lines, the sum of the distinct number in all substrings of length w for each query.
 

Sample Input
  
  
7 1 1 2 3 4 4 5 3 1 2 3 0
 

Sample Output
  
  
7 10 12
 

Source
        本题给定一个序列,然后给定若干连续的查询长度,求每个该长度的连续区间内不同元素的个数和。
      此题容易让人误导以为是线段树可以以解决的。但本题的解法是DP。DP解本题是相当合理的。假设我们知道了长度为i的连续区间内不同元素个数和dp[i],则长度为i+1的为dp[i+1]-lat_len+sum;las_len为最后长度为i的区间内不相同的元素个数,sum为相同元素距离大于i的不相同的元素的个数。
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

const int MAXN=1000000+100;
int da[MAXN],pre[MAXN];
long long dis[MAXN],dp[MAXN],las_len[MAXN];//必须用long long型

int main()
{
	int n,i,w,q,sum,t;
	while(scanf("%d",&n),n)
	{
		if(!n)break;
		memset(pre,-1,sizeof(pre));
		memset(dis,0,sizeof(dis));
	
		for(i=0;i<n;i++)
		{
			scanf("%d",&da[i]);
			if(dis[i]!=-1)
				dis[i-pre[da[i]]]++;
			pre[da[i]]=i;
		}

		memset(pre,0,sizeof(pre));
		las_len[n]=0;
		for(i=n-1;i>=0;i--)
		{
			if(pre[da[i]]==0)
				las_len[i]=las_len[i+1]+1;
			else las_len[i]=las_len[i+1];
			pre[da[i]]=1;
		}

		dp[1]=n;sum=n;
		for(i=2;i<=n;i++)
		{
			dp[i]=dp[i-1]-las_len[n-i+1];
			sum-=dis[i-1];
			dp[i]+=sum;
		}

		scanf("%d",&q);
		while(q--)
		{
			scanf("%d",&t);
			if(t>=n)printf("%I64d\n",dp[n]);
			else printf("%I64d\n",dp[t]);
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值