poj2104(主席树)

K-th Number
Time Limit: 20000MS Memory Limit: 65536K
Total Submissions: 35704 Accepted: 11396
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?"
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 10 9 by their absolute values --- the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.
 
 
题解:
     本题要求给定区间的第k小元素,可以用划分树,在我的博客poj2104划分树解法有划分树的解法,至于划分树可以参考划分树
本题要用到的主席树相关知识在主席树读书笔记可以找到。主席树的每个节点对应一颗线段树,每个节点的意义为离散后原序列的某个后缀。在每棵线段树中若元素出现则标记为1,问题可以转化为求区间的前k个数,第k个数即为第k小的元素,在区间上操作是线段树的特色。
贴段代码:
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;

const int MAXN=100000+100;
const int MAXM=MAXN*20;

int tot,n,m;
int da[MAXN],sDa[MAXN];
int leftChild[MAXM],rightChild[MAXM],wei[MAXM],chairTNode[MAXM];


/**********************************
*参数:待处理元素区间
*功能:建立一棵空线段树
*返回值:返回根节点下标
***********************************/
int Build(int left,int right)
{
	int id=tot++;
	wei[id]=0;
	if(left<right)
	{
		int mid=(left+right)>>1;
		leftChild[id]=Build(left,mid);
		rightChild[id]=Build(mid+1,right);
	}
	return id;
}


int Update(int root,int pos,int val)
{
	int l=1,r=m,mid,newRoot=tot++,retRoot=newRoot;
	wei[newRoot]=wei[root]+val;
	while(l<r)
	{
		mid=(l+r)>>1;
		if(pos<=mid)
		{
			//确定节点孩子节点
			leftChild[newRoot]=tot++;
			rightChild[newRoot]=rightChild[root];

			//确定待跟新节点以及历史版本
			newRoot=leftChild[newRoot];
			root=leftChild[root];

			r=mid;
		}
		else 
		{
			rightChild[newRoot]=tot++;
			leftChild[newRoot]=leftChild[root];
			newRoot=rightChild[newRoot];
			root=rightChild[root];
			l=mid+1;
		}
		wei[newRoot]=wei[root]+val;
	}
	return retRoot;
}

int Query(int leftRoot,int rightRoot,int k)
{
	int  l=1,r=m,mid;
	while(l<r)
	{
		mid=(l+r)>>1;
		if(wei[leftChild[leftRoot]]-wei[leftChild[rightRoot]]>=k)//第k小值在左子树
		{
			//确定查找新区间
			leftRoot=leftChild[leftRoot];
			rightRoot=leftChild[rightRoot];

			r=mid;
		}
		else 
		{
			k-=wei[leftChild[leftRoot]]-wei[leftChild[rightRoot]];
			leftRoot=rightChild[leftRoot];
			rightRoot=rightChild[rightRoot];
			l=mid+1;
		}
	}
	return l;
}

int main()
{
	int q,i;
	int ql,qr,k;
	while(scanf("%d%d",&n,&q)!=EOF)
	{
		m=0;
		tot=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&da[i]);
			sDa[i]=da[i];
		}
		sort(sDa+1,sDa+n+1);
		m=unique(sDa+1,sDa+1+n)-sDa-1;
		chairTNode[n+1]=Build(1,m);
		//cout<<"**********"<<endl;

		for(i=n;i>=1;i--)
		{
			int pos=lower_bound(sDa+1,sDa+1+m,da[i])-sDa;
			chairTNode[i]=Update(chairTNode[i+1],pos,1);
		}
		while(q--)
		{
			scanf("%d%d%d",&ql,&qr,&k);
			printf("%d\n",sDa[Query(chairTNode[ql],chairTNode[qr+1],k)]);
		}
	}
	system("pause");
	return 0;
}

 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值