poj1204(AC自动机)

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 8153 Accepted: 3086 Special Judge

Description

Word puzzles are usually simple and very entertaining for all ages. They are so entertaining that Pizza-Hut company started using table covers with word puzzles printed on them, possibly with the intent to minimise their client's perception of any possible delay in bringing them their order.

Even though word puzzles may be entertaining to solve by hand, they may become boring when they get very large. Computers do not yet get bored in solving tasks, therefore we thought you could devise a program to speedup (hopefully!) solution finding in such puzzles.

The following figure illustrates the PizzaHut puzzle. The names of the pizzas to be found in the puzzle are: MARGARITA, ALEMA, BARBECUE, TROPICAL, SUPREMA, LOUISIANA, CHEESEHAM, EUROPA, HAVAIANA, CAMPONESA.

Your task is to produce a program that given the word puzzle and words to be found in the puzzle, determines, for each word, the position of the first letter and its orientation in the puzzle.

You can assume that the left upper corner of the puzzle is the origin, (0,0). Furthemore, the orientation of the word is marked clockwise starting with letter A for north (note: there are 8 possible directions in total).

Input

The first line of input consists of three positive numbers, the number of lines, 0 < L <= 1000, the number of columns, 0 < C <= 1000, and the number of words to be found, 0 < W <= 1000. The following L input lines, each one of size C characters, contain the word puzzle. Then at last the W words are input one per line.

Output

Your program should output, for each word (using the same order as the words were input) a triplet defining the coordinates, line and column, where the first letter of the word appears, followed by a letter indicating the orientation of the word according to the rules define above. Each value in the triplet must be separated by one space only.

Sample Input

20 20 10
QWSPILAATIRAGRAMYKEI
AGTRCLQAXLPOIJLFVBUQ
TQTKAZXVMRWALEMAPKCW
LIEACNKAZXKPOTPIZCEO
FGKLSTCBTROPICALBLBC
JEWHJEEWSMLPOEKORORA
LUPQWRNJOAAGJKMUSJAE
KRQEIOLOAOQPRTVILCBZ
QOPUCAJSPPOUTMTSLPSF
LPOUYTRFGMMLKIUISXSW
WAHCPOIYTGAKLMNAHBVA
EIAKHPLBGSMCLOGNGJML
LDTIKENVCSWQAZUAOEAL
HOPLPGEJKMNUTIIORMNC
LOIUFTGSQACAXMOPBEIO
QOASDHOPEPNBUYUYOBXB
IONIAELOJHSWASMOUTRK
HPOIYTJPLNAQWDRIBITG
LPOINUYMRTEMPTMLMNBO
PAFCOPLHAVAIANALBPFS
MARGARITA
ALEMA
BARBECUE
TROPICAL
SUPREMA
LOUISIANA
CHEESEHAM
EUROPA
HAVAIANA
CAMPONESA

Sample Output

0 15 G
2 11 C
7 18 A
4 8 C
16 13 B
4 15 E
10 3 D
5 1 E
19 7 C
11 11 H

Source

 

本题打算用确定性有限状态自动机,不知怎么出错了,看了别人的代码才发现普通字典树+深搜亦可以

粘贴大牛代码

#include <iostream>
#include<string>
#include<cstring>
#include<cstdio>
#include <vector>
#include <queue>
using namespace std;
#define	LETTERS 26
int nNodesCount = 0;
struct CNode 
{
	CNode * pChilds[LETTERS];
	CNode * pPrev; //前缀指针
	bool bBadNode; //是否是危险节点
	void Init() 
	{
		memset(pChilds,0,sizeof(pChilds));
		 bBadNode = false;
		pPrev = NULL;
	}
};

CNode Tree[500]; //10个模式串,每个10个字符,每个字符一个节点,也只要100个节点
void Insert( CNode * pRoot, char * s)
{//将模式串s插入trie树
	for( int i = 0; s[i]; i ++ ) 
	{
		if( pRoot->pChilds[s[i]-'A'] == NULL)
		{
			pRoot->pChilds[s[i]-'A'] = Tree + nNodesCount;
			nNodesCount ++;
		//	printf("%d   %d\n",s[i]-'A',nNodesCount);
		}
		pRoot = pRoot->pChilds[s[i]-'A'];
	}
	pRoot-> bBadNode = true;
}

void BuildDfa( )
{ //在trie树上加前缀指针
	for( int i = 0;i < LETTERS ;i ++ )
		Tree[0].pChilds[i] = Tree + 1;
	Tree[0].pPrev = NULL;
	Tree[1].pPrev = Tree;
	deque<CNode * > q;
	q.push_back(Tree+1);
	while( ! q.empty() )
	{
		CNode * pRoot = q.front();
		q.pop_front();
		for( int i = 0; i < LETTERS ; i ++ )
		{
			CNode * p = pRoot->pChilds[i];
			if( p) 
			{
				CNode * pPrev = pRoot->pPrev;
				while( pPrev )
				{
					if( pPrev->pChilds[i] )
					{
						p->pPrev = pPrev->pChilds[i];
					      if( p->pPrev-> bBadNode) 
						    p-> bBadNode = true; 
   //自己的pPrev指向的节点是危险节点,则自己也是危险节点
						break;
					}
					else
						pPrev = pPrev->pPrev;
				}
				q.push_back(p);
			}
		}
	}  //对应于while( ! q.empty() )
}


bool SearchDfa(char * s)
{//返回值为true则说明包含模式串
	CNode * p = Tree + 1;
	for( int i = 0; s[i] ;i ++ )
	{
		while(true) 
		{ 
			if( p->pChilds[s[i]-'A'])
			{
				p = p->pChilds[s[i]-'A'];
				if( p-> bBadNode)
					return true;
				break;
			}
			else 
				p = p->pPrev;
		}
	}
	return false;
}
int main()
{
	nNodesCount = 2;
	int M,N,i,w;
	scanf("%d%d%d",&N,&w,&M);  	//N个模式串,M个句子
	for( i = 0;i < N; i ++ ) 
	{
		char s[30];
		scanf("%s",s);
	//	printf("^^^^\n");//
		Insert(Tree + 1,s);
	}

	BuildDfa();
	for( i = 0 ;i < M;i ++ ) 
	{
		char s[200];
		scanf("%s",s);
		cout << SearchDfa(s) << endl;
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值