hdu2639(第k大值+01背包)

Bone Collector II

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1526    Accepted Submission(s): 785


Problem Description
The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link: http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the K-th maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
3 5 10 2 1 2 3 4 5 5 4 3 2 1 5 10 12 1 2 3 4 5 5 4 3 2 1 5 10 16 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
12 2 0
 

Author
teddy
 

Source
 

Recommend
teddy
 
本题与传统01背包不同,不是求最大值而是求第k大值,如果最终结果没有没有k个不同的元素,则为0
我们可以在进行01背包计算的时候多加一维,表示为当前计算出的第k大价值值,加进一物品的的第k大价值值肯定是在前一个物品前k大价值值的基础上运算得到的。
 
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;

const int MAX=100+10;
struct node
{
	int vol,val;
}Bone[MAX];
int dp[1000+10][30+5];
int tmp[30+5];

bool cmp(int a,int b)
{
	return a>b;
}

int main()
{
	int cas,n,v,k,t,i,j,id,s;
	cin>>cas;
	while(cas--)
	{
		scanf("%d%d%d",&n,&v,&k);
		for(i=1;i<=n;i++)
		{
			scanf("%d",&Bone[i].val);
		}
		for(i=1;i<=n;i++)
		{
			scanf("%d",&Bone[i].vol);
		}



		memset(dp,0,sizeof(dp));
		memset(dp,0,sizeof(dp));
		for(i=1;i<=n;i++)
		{
			for(j=v;j>=Bone[i].vol;j--)
			{
				id=0;
				for(t=0;t<k;t++)
				{
					tmp[id++]=dp[j][t];
					tmp[id++]=dp[j-Bone[i].vol][t]+Bone[i].val;
				}

				sort(tmp,tmp+id,cmp);
				dp[j][0]=tmp[0];
				s=1;
				for(t=1;t<id&&s<k;t++)//如果第k大值不存在,则没有k个,dp[j][k]=0,符合题意
				{
					if(tmp[t]!=tmp[t-1])
						dp[j][s++]=tmp[t];
				}
			//	printf("%d  ",s);
			}
		//	printf("^^\n");
		}
		//printf("\n&&&&&&&\n");

		printf("%d\n",dp[v][k-1]);//
	}
	return 0;
}

 
 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值