hdu4473(排列组合)

Exam

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 497    Accepted Submission(s): 203


Problem Description
Rikka is a high school girl suffering seriously from Chūnibyō (the age of fourteen would either act like a know-it-all adult, or thinks they have special powers no one else has. You might google it for detailed explanation) who, unfortunately, performs badly at math courses. After scoring so poorly on her maths test, she is faced with the situation that her club would be disband if her scores keeps low.
Believe it or not, in the next exam she faces a hard problem described as follows.
Let’s denote f(x) number of ordered pairs satisfying (a * b)|x (that is, x mod (a * b) = 0) where a and b are positive integers. Given a positive integer n, Rikka is required to solve for f(1) + f(2) + . . . + f(n).
According to story development we know that Rikka scores slightly higher than average, meaning she must have solved this problem. So, how does she manage to do so?
 

Input
There are several test cases.
For each test case, there is a single line containing only one integer n (1 ≤ n ≤ 10 11).
Input is terminated by EOF.
 

Output
For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is the desired answer.
 

Sample Input
  
  
1 3 6 10 15 21 28
 

Sample Output
  
  
Case 1: 1 Case 2: 7 Case 3: 25 Case 4: 53 Case 5: 95 Case 6: 161 Case 7: 246
 

Source
 
对于f[x],xmod(a*b)=0,即存在c,使a*b*c=x,f[x]即为这样的a,b的组合个数;题目要求的是f[1]+f[2]+f[3]+…+f[n-1]+f[n]的和,且n很大。题目数据之大,打消了直接枚举的念头,必须用算法降低时间复杂度。
f[1]+f[2]+f[3]+…+f[n-1]+f[n]的和即可这样理解:a*b*c<=n,求这样的a,b,c的组合个数。(若将a、b、c按递增顺序排列)
    A、a=b=c,
    B、a=b<c
    C、a<b=c
    D、a<b<c
由于题目abc可以任意排列,故最终答案为A+(B+C)*3+D*6,剩下的任务就是求ABCD了。
 
#include<iostream>
#include<cmath>
#include<cstdio>
using namespace std;

int main()
{
	__int64 n,ans,i,j,a,b,tag=1;
	while(~scanf("%I64d",&n))
	{
		ans=0;
		a=pow((double)n,1.0/3.0);
		while(a*a*a<n)a++;
		if(a*a*a>n)a--;
		ans+=a;
		for(i=1;i<=a;i++)///枚举a的可能取值
		{
			__int64 tmp=n/i;
			b=sqrt(tmp);
			while(b*b<tmp)
				b++;
			if(b*b>tmp)
				b--;
			ans+=(b-i+tmp/i-i)*3;
			for(j=i+1;j<=b;j++)
				ans+=(tmp/j-j)*6;
		}
		printf("Case %I64d: %I64d\n",tag++,ans);
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值