UVALive 4329 Ping pong(树状数组)

原题链接

Problem Description

N (3 ≤ N ≤ 20000) ping pong players live along a west-east street(consider the street as a line segment).
Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If
two players want to compete, they must choose a referee among other ping pong players and hold the
game in the referee’s house. For some reason, the contestants can’t choose a referee whose skill rank is
higher or lower than both of theirs. The contestants have to walk to the referee’s house, and because
they are lazy, they want to make their total walking distance no more than the distance between their
houses. Of course all players live in different houses and the position of their houses are all different. If
the referee or any of the two contestants is different, we call two games different. Now is the problem:
how many different games can be held in this ping pong street?

Input

The first line of the input contains an integer T (1 ≤ T ≤ 20), indicating the number of test cases,
followed by T lines each of which describes a test case.
Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N
distinct integers a1, a2 … aN follow, indicating the skill rank of each player, in the order of west to east
(1 ≤ ai ≤ 100000, i = 1 … N).

Output

For each test case, output a single line contains an integer, the total number of different games.

Sample Input

1
3 1 2 3

Sample Output

1

题目大意

有n个乒乓球爱好者排成一排,每个人都有自己的能力值 ai ,现要组织比赛,要求有两位选手和一位裁判,裁判的位置必须在选手之间且能力值也要在选手之间,给出每个人的能力值,问可以组织的比赛场数有多少。

解题思路

考虑第i个人当裁判,设 a1 ai1 中有 ci 个值比 ai 小,就有(i-1)- ci 个比 ai 大,同理假设 ai+1 an di 个比 ai 小。所以当i为裁判时,比赛数有 ci (n-i- di )+(i-1- ci ) di
ci 时,从左到右扫描所有 ai ,v[j]表示目前所有考虑过的 ai 中是否存在 ai ==j, ci 就是前缀和v[1]+v[2]+v[3]+···v[ ai1 ]。使用BIT维护v数组,用同样的方法算出d数组,最后把答案累加。

AC代码

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<string>
#include<queue>
#include<list>
#include<stack>
#include<set>
#include<map>
#define ll long long
#define ull unsigned long long
#define rep(i,a,b) for (int i=(a),_ed=(b);i<_ed;i++)
#define fil(a,b) memset((a),(b),sizeof(a))
#define cl(a) fil(a,0)
#define pb push_back
#define PI 3.1415927
#define inf 0x3f3f3f3f
using namespace std;
int a[20005];
int d[20005];
int c[20005];
int v[100005];
int lowbit(int x) {return x&(-x);}
int sum(int x)
{
    int res=0;
    while(x>0)
    {
        res+=v[x];
        x-=lowbit(x);
    }
    return res;
}
void add(int n,int x,int d)
{
    while(x<=n)
    {
        v[x]+=d;
        x+=lowbit(x);
    }
}

int main(void)
{
    int t,n;
    cin>>t;
    while(t--)
    {
        cl(a);
        cl(d);
        cl(c);
        cl(v);
        scanf("%d",&n);
        rep(i,1,n+1)
        {
            scanf("%d",&a[i]);
            add(100003,a[i],1);
            c[i]=sum(a[i]-1);
        }
        cl(v);
        for(int i=n;i>=1;i--)
        {
            add(100003,a[i],1);
            d[i]=sum(a[i]-1);
        }
        ll res=0;
        rep(i,2,n)
        {
            res=res+c[i]*(n-i-d[i])+(i-c[i]-1)*d[i];
        }
        printf("%lld\n",res);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值