HDU 1.1.5解题报告

1.1.5这道题的难度还算可以,思想有些灵活,如果我没记错昨天我做这个题是卡的最多的一次,一开始怎么也想不通啊

一块来看description

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 
 
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 
 
Sample Input
2
4 1 2 3 4
5 1 2 3 4 5
 
Sample Output
10
15
 
题意说第一行先输入一个整数N,表示接下来要进行的加法运算的次数
接下来的N行,每一行第一个输入的数M代表此行要相加起来的数字的个数,最后输出结果。
实现这个过程,仍然靠的是循环。
第一个循环来控制进行加法运算的行数,从1到N进行循环
之后再加一个循环,是在每行中,输入一个数,加到sum上,从1到M,最后输出
talk is cheap,here the the code is:
#include <iostream>
using namespace std;
int main()
{
int m,n,i,j,sum,it;
cin>>n;
for(i=1;i<=n;i++)
{
cin>>m;
sum=0;
for(j=1;j<=m;j++)
{
cin>>it;
sum+=it;
}
cout<<sum<<endl;
}
return 0;
}
提交测试,一遍Accepted
c语言代码我也做一下尝试
<pre name="code" class="cpp">#include <stdio.h>
int main()
{
int m,n,sum,it;
scanf("%d",&n);
while(n--)
{
sum=0;
scanf("%d",&m);
while(m--)
{
scanf("%d",&it);
sum+=it;}
printf("%d\n",sum);
}
return 0;
}
同样是一遍accepted
 
     
个人认为,c++比c还是要更方便的。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值