HDU 1026 Ignatius and the Princess I bfs优先队列

Ignatius and the Princess I

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 8   Accepted Submission(s) : 5
Special Judge
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166's castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166's room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.

Input

The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.

Output

For each test case, you should output "God please help our poor hero." if Ignatius can't reach the target position, or you should output "It takes n seconds to reach the target position, let me show you the way."(n is the minimum seconds), and tell our hero the whole path. Output a line contains "FINISH" after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.

Sample Input

5 6
.XX.1.
..X.2.
2...X.
...XX.
XXXXX.
5 6
.XX.1.
..X.2.
2...X.
...XX.
XXXXX1
5 6
.XX...
..XX1.
2...X.
...XX.
XXXXX.

Sample Output

It takes 13 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
FINISH
It takes 14 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
14s:FIGHT AT (4,5)
FINISH
God please help our poor hero.

FINISH

http://acm.hdu.edu.cn/showproblem.php?pid=1026

// 题意 就是从1,1点到n,m点 问最短时间 走到数字的地方 就在数字的地方停留多长

// 优先队列 时间少的必须 先搜完 如果一般队列没顺序 在数字的地方时间会长 时长的先搜了 (标记了) 可能会有更好的方案 就走不到这点了

//此题 还要记录 路径 一般都是 记录前驱 (一个点的前驱只有一个 而 后驱有很多)

//倒回去一个找 可以压入栈 然后 输出 也可以采用递归的方法

#include<stdio.h>
#include<queue>
#include<string.h>
#include<algorithm>
using namespace std;
const int inf=0x3f3f3f3f;
char ap[110][110];
int dir[4][2]= {1,0,0,1,-1,0,0,-1};
int vis[110][110];
int n,m,sum,flag;
struct node
{
    int x,y,step;
    bool operator <(const node &a)const
    {
        return step>a.step;
    }
} ft,et;

node pre[110][110];
int k;
void dg(int x,int y)
{
    if(pre[x][y].x==0&&pre[x][y].y==0)
    {
        k=1;
        if(ap[x][y]!='X'&&ap[x][y]!='.')
        {
            printf("%ds:(%d,%d)->(%d,%d)\n",k++,pre[x][y].x,pre[x][y].y,x,y);
            for(int i=0; i<ap[x][y]-'0'; i++)
                printf("%ds:FIGHT AT (%d,%d)\n",k++,x,y);
        }
        else
        {
            printf("%ds:(%d,%d)->(%d,%d)\n",k++,pre[x][y].x,pre[x][y].y,x,y);
        }
        return ;
    }
    dg(pre[x][y].x,pre[x][y].y);
    if(ap[x][y]!='X'&&ap[x][y]!='.')
    {
        printf("%ds:(%d,%d)->(%d,%d)\n",k++,pre[x][y].x,pre[x][y].y,x,y);
        for(int i=0; i<ap[x][y]-'0'; i++)
            printf("%ds:FIGHT AT (%d,%d)\n",k++,x,y);

    }
    else
        printf("%ds:(%d,%d)->(%d,%d)\n",k++,pre[x][y].x,pre[x][y].y,x,y);


    //return 1;
}

int pd(node a)
{
    if(a.x>=n||a.x<0||a.y>=m||a.y<0||ap[a.x][a.y]=='X')
        return 1;
    return 0;

}
void bfs()
{
    int i;
    priority_queue<node>q;
    ft.x=0;
    ft.y=0;
    ft.step=0;
    q.push(ft);
    while(!q.empty())
    {
        ft=q.top();
        q.pop();
        if(ft.x==n-1&&ft.y==m-1)
        {
            flag=1;
            sum=ft.step;
            return ;
        }
        for(i=0; i<4; i++)
        {
            et.x=ft.x+dir[i][0];
            et.y=ft.y+dir[i][1];
            et.step=ft.step+1;
            if(pd(et)||vis[et.x][et.y]==1) continue;
            if(ap[et.x][et.y]=='.')
            {
                vis[et.x][et.y]=1;
                pre[et.x][et.y].x=ft.x; //记录前驱
                pre[et.x][et.y].y=ft.y;
                q.push(et);
            }
            else
            {
                et.step=et.step+ap[et.x][et.y]-'0';
                vis[et.x][et.y]=1;
                pre[et.x][et.y].x=ft.x;
                pre[et.x][et.y].y=ft.y;
                q.push(et);
            }

        }

    }
}


int main()
{
    int i;
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        flag=0;
        for(i=0; i<n; i++)
            scanf("%s",ap[i]);
        memset(vis,0,sizeof(vis));
        vis[0][0]=1;
        bfs();
        if(flag==0)
            printf("God please help our poor hero.\nFINISH\n");
        else
        {
            printf("It takes %d seconds to reach the target position, let me show you the way.\n",sum);
            dg(n-1,m-1);
            printf("FINISH\n");
        }

    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值