HDU2182 Lost Cows

Lost Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11162 Accepted: 7176

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands. 

Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow. 

Given this data, tell FJ the exact ordering of the cows. 

Input

* Line 1: A single integer, N 

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on. 

Output

* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1

Source

USACO 2003 U S Open Orange

http://poj.org/problem?id=2182

题意:给出的数字表示从第2到第n只牛左边有几个比它序号小的牛,要求每个位置的牛的编号是多少

//想做到线段树的题在大神博客里看到了

//感觉逆推 标记一下就 OK了没必要 线段树啊 算了下 8000*8000  暴力过了

#include<stdio.h>
#include<string.h>
int main()
{
    int vis[10000],n,i,a[10000],b[10000],j,ans;
    scanf("%d",&n);
    for(i=2; i<=n; i++)
        scanf("%d",&a[i]);
    memset(vis,0,sizeof(vis));
    a[1]=0;
    for(i=n; i>=1; i--) //从右往左
    {
        ans=0;
        for(j=1; j<=n; j++)
            if(vis[j]==0)
            {
                if(ans==a[i])
                {
                    b[i]=j;
                    vis[j]=1; //标记用过的
                    break;
                }
                ans++;
            }
    }
    for(i=1; i<=n; i++)
        printf("%d\n",b[i]);

    return 0;
}

推荐下大神的 

http://blog.csdn.net/libin56842/article/details/13021117

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int n,ans[1000000],s[1000000];

struct node
{
    int l,r,n;
} a[1000000];

void init(int l,int r,int i)
{
    a[i].l = l;
    a[i].r = r;
    a[i].n = r-l+1;//该区间内能放的数字个数
    if(l!=r)
    {
        int mid = (l+r)/2;
        init(l,mid,2*i);
        init(mid+1,r,2*i+1);
    }
}

int insert(int i,int x)
{
    a[i].n--;    //更新
    if(a[i].l == a[i].r)
        return a[i].l;
    if(a[2*i].n>=x)//左子树的数字足够,则走左子树
        insert(2*i,x);
    else//否则走右子树,并且将子树视为新树,编号从1开始
        insert(2*i+1,x-a[2*i].n);
}

int main()
{
    int i,j;
    while(~scanf("%d",&n))
    {
        s[1] = 0;
        for(i = 2; i<=n; i++)
            scanf("%d",&s[i]);
        init(1,n,1);
        for(i = n; i>=1; i--)//逆推
            ans[i] = insert(1,s[i]+1);
        for(i = 1; i<=n; i++)
            printf("%d\n",ans[i]);
    }

    return 0;
}

下面的还是快一点


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值