HDU5914 Harmonic Value Description

Harmonic Value Description

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 410    Accepted Submission(s): 259
Special Judge


Problem Description
The harmonic value of the permutation p1,p2,pn is
i=1n1gcd(pi.pi+1)

Mr. Frog is wondering about the permutation whose harmonic value is the strictly k-th smallest among all the permutations of [n].
 

Input
The first line contains only one integer T ( 1T100 ), which indicates the number of test cases.

For each test case, there is only one line describing the given integers n and k ( 12kn10000 ).
 

Output
For each test case, output one line “Case #x: p1 p2  pn ”, where x is the case number (starting from 1) and p1 p2  pn is the answer.
 

Sample Input
  
  
2 4 1 4 2
 

Sample Output
  
  
Case #1: 4 1 3 2 Case #2: 2 4 1 3
 

Source

2016中国大学生程序设计竞赛(长春)-重现赛  

题意很蛋疼 2组样例 4 1 求 1,2,3,4全排列 每个排列都有一个i=1n1gcd(pi.pi+1)

(求相邻两个数的gcd)

如果值相同也算在一个排名    求第k小的其中一个排列

大胆猜想吧(2k<n)    把n个偶数放在一起就能多(n-1)

然后其他的数放按顺序输出(还是可以两两GCD为1猜想的)

#include<stdio.h>
#include<string.h>
int vis[10010];
int main()
{
    int t,i,h,n,k;
    scanf("%d",&t);
    for(h=1; h<=t; h++)
    {
        scanf("%d%d",&n,&k);
        memset(vis,0,sizeof(vis));
        for(i=1; i<=k; i++)
            vis[2*i]=1;
        printf("Case #%d:",h);
        for(i=1; i<=n; i++)
            if(vis[i])
                printf(" %d",i);
        for(i=1; i<=n; i++)
            if(!vis[i])
                printf(" %d",i);
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值