HDU2141 Can you find it?(二分)

Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 30394    Accepted Submission(s): 7578


Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
  
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
  
  
Case 1: NO YES NO
 

Author
wangye
 

Source
http://acm.split.hdu.edu.cn/showproblem.php?pid=2141

题意 给你三个数量分别为 L,N,M的序列   有S个数     分别从三个数组里面拿出一个 看三个数之和能不能为 这些数

如果暴力的话肯定是超时的 把两个数组相加得到500 *500 的数组 二分

我是借助SET实现的   好像 一下子内存一下子大了好多倍 不知道为什么 G++交没过 C++就过了

大概是这个原因吧  http://blog.csdn.net/xky140610205/article/details/75212155

#include<stdio.h>
#include<set>
using namespace std;
set<int>ss;
set<int>::iterator it;
int casee;
int a[555],c[555];
int main()
{
    casee=1;
    int l,j,n,m,i,dt,jl,sum;
    while(scanf("%d %d %d",&l,&n,&m)!=EOF)
    {
        ss.clear();
        for(i=1; i<=l; i++)
            scanf("%d",&a[i]);
        for(i=1; i<=n; i++)
        {
            scanf("%d",&jl);
            for(j=1; j<=l; j++)
            {
                dt=jl+a[j];
                ss.insert(dt);
            }
        }

        for(i=1; i<=m; i++)
            scanf("%d",&c[i]);

        int s,gg;
        printf("Case %d:\n",casee++);
        scanf("%d",&s);
        while(s--)
        {
            scanf("%d",&sum);
            int flag=0;
            for(j=1; j<=m; j++)
            {
                gg=sum-c[j];
                it=ss.find(gg);
                if(it!=ss.end())
                {
                    printf("YES\n");
                    flag=1;
                    break;
                }
            }
            if(!flag) printf("NO\n");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值