2017acm福建省赛FZU2272 Frog

Problem 2272 Frog

Accept: 9    Submit: 11
Time Limit: 1000 mSec    Memory Limit : 262144 KB

Problem Description

Therearex frogs and y chicken in a garden. Kim found there are n heads and m legs in the garden. Please tell Kim how many frogs and chicken are there. (A frog has 4 legs, and a chicken has 2 legs.)

Input

First line contains an integer T (1 ≤ T ≤ 10), represents there are T test cases.

For each test case: Two number n and m.

1<=n, m <=100000. The data is legal.

Output

For each test case, output two numbers A and B – the number of frog and the number of chicken.

Sample Input

2
2 6
2 4

Sample Output

1 1
0 2

Source

第八届福建省大学生程序设计竞赛-重现赛(感谢承办方厦门理工学院)
http://acm.fzu.edu.cn/problem.php?pid=2272
鸡兔同笼问题 解一个二元一次方程组就OK

#include<stdio.h>
using namespace std;
int main()
{
   int t,n,m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&n,&m);
        int xf=(m-2*n)/2;
        printf("%d ",xf);
        printf("%d\n",n-xf);
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值