1085. Perfect Sequence (25)

Given a sequence of positive integers and another positive integer p. The sequence is said to be a "perfect sequence" if M <= m * p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (<= 105) is the number of integers in the sequence, and p (<= 109) is the parameter. In the second line there are N positive integers, each is no greater than 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:
10 8
2 3 20 4 5 1 6 7 8 9
Sample Output:

8


#include<cstdio>
#include<algorithm>
using namespace std;
int a[100005],n,p;
int binarysearch(int i,long long x){
if (a[n-1]<=x) return n;
int left=i-1;
int right=n-1;
while(left<right) {
int mid=(left+right)/2;
if(a[mid]<=x) {
left=mid+1;
}
        else  right=mid; 
}
return left; //left==right

int main(){
scanf("%d%d",&n,&p);
for (int i=0;i<n;i++) {
scanf("%d",&a[i]);
}
sort(a,a+n);
int ans=1,j;
for (int i=0;i<n;i++) {
j=binarysearch(i,(long long)(a[i]*p));
ans=max(ans,j-i);
}
printf("%d",ans);
}

另解(用双指针):

#include<cstdio>
#include<algorithm>
using namespace std;
int main() {
int n,p,a[100005];
scanf("%d%d",&n,&p);
for (int i=0;i<n;i++){
scanf("%d",&a[i]);
}
sort(a,a+n);
int cnt=1;
int i=0,j=0;
while(i<n&&j<n) {
while(j<n&&a[j]<=(long long)a[i]*p){
cnt=max(cnt,j-i+1);
j++;
}
i++;
}
printf("%d\n",cnt);
return 0;

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值