HDU 1022:Train Problem I(堆栈的基本应用)

Train Problem I

Time limit 1000 ms Memory limit 32768 kB OS Windows


Problem Description

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can’t leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
这里写图片描述这里写图片描述这里写图片描述

Input

The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.

Output

The output contains a string “No.” if you can’t exchange O2 to O1, or you should output a line contains “Yes.”, and then output your way in exchanging the order(you should output “in” for a train getting into the railway, and “out” for a train getting out of the railway). Print a line contains “FINISH” after each test case. More details in the Sample Output.

Sample Input

3 123 321
3 123 312

Sample Output

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

Hint

For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can’t let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output “No.


题意:

输入火车的进站次序与火车的出站次序,看是否能按照这种次序进站出站,如果可以输出Yes,并输出in和out的次序,如果不能则输出No

解题思路:

典型使用堆栈的题目,首先第一辆火车入栈,接着,每次判断栈顶是否和接下来要出站的火车相同,若相同则出栈,否则把后一辆进站火车入栈,记录中间过程,直到所有进站的火车都已经进站。如果栈为空,则说明所有的火车都可以出站,输出Yes等等。否则说明还有火车没能出站,输出No。


Code:

#include <iostream>
#include <stack>
#include <string>
using namespace std;

int ans[100000];
const int in=0,out=1;

stack<char> s;

int main()
{
    string s1,s2;
    int n;
    while(cin>>n>>s1>>s2)
    {

        while(!s.empty())
            s.pop();
        int p=0,q=0,len=0;
        s.push(s1[p++]);
        ans[len++]=in;
        while(q<n)
        {
            if(!s.empty()&&s.top()==s2[q]&&q<n)
            {
                s.pop();
                ans[len++]=out;
                q++;
            }
            else if(p<n)
            {
                ans[len++]=in;
                s.push(s1[p++]);
            }
            else
            {
                break;
            }
        }
        if(s.empty())
        {
            cout<<"Yes."<<endl;
            for(int i=0;i<len;i++)
            {
                if(ans[i]==in)
                    cout<<"in"<<endl;
                else
                    cout<<"out"<<endl;
            }
            cout<<"FINISH"<<endl;
        }
        else
        {
            cout<<"No."<<endl;
            cout<<"FINISH"<<endl;
        }

    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值