E - Aggressive cows(二分)

Aggressive cows

Time limit:1000 ms Memory limit:65536 kB OS:Linux


Problem Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

  • Line 1: Two space-separated integers: N and C

  • Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

  • Line 1: One integer: the largest minimum distance
    Sample Input

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.


题意:

有一个很长的仓库,按照直线上面分布了N个牛棚,其位置分别为Xi,有C头牛,需要我们把牛安放在牛棚里面,但是牛之间的距离小会让牛变得有攻击性,所以我们需要合理安排牛的牛棚,让所有牛之间的最短距离最大。

解题思路:

二分答案。对设最小间隔为X,从第一个牛棚开始放置牛,每次放置放置牛时如果该牛棚据上一个牛棚的距离小于X,则不在此处放牛,转置下一个。过程中统计放下的牛的个数,如果牛的个数>C,说明可以按照最短距离为X的方法放置。
如果X可行,就继续找更大的,否则就找比X小的。


Code:

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;

const int maxn=100000+4;

int s[maxn];//牛棚的位置
int N,C;

bool f(int x)
{
    int cnt=0,p=0;
    for(int i=0;i<N;)
    {
        while(i<N&&s[i]-s[p]<x)
            i++;
        cnt++;
        p=i;
        if(cnt>=C)
            return true;
    }
    return false;
}

int bs()
{
    int lo=0,hi=10000000000;
    int ans;
    while(lo<=hi)
    {
        int mid=((hi-lo)>>1)+lo;
        if(f(mid))
        {
            ans=mid;
            lo=mid+1;
        }
        else
            hi=mid-1;
    }
    return ans;
}

int main()
{

    while(scanf("%d%d",&N,&C)!=EOF)
    {
        for(int i=0;i<N;i++)
        {
            scanf("%d",s+i);
        }
        sort(s,s+N);
        int ans=bs();
        cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值