B - UmBasketella (三分)

Twenty-four point

Time limit:1000 ms Memory limit:65536 kB OS:Linux


Problem Description

In recent days, people always design new things with multifunction. For instance, you can not only use cell phone to call your friends, but you can also use your cell phone take photographs or listen to MP3. Another example is the combination between watch and television. These kinds of multifunction items can always improve people’s daily life and are extremely favored by users.

The company Mr. Umbrella invented a new kind umbrella “UmBasketella” for people in Rainbow city recently and its idea also comes from such multifunction–the combination of umbrella and daily necessities. This kind of umbrella can be used as a basket and you can put something you want to carry in it. Since Rainbow city rains very often, such innovative usage is successful and “UmBasketella” sells very well. Unfortunately, the original “UmBasketella” do not have an automatic volume control technology so that it is easily damaged when users try to put too many things in it. To solve this problem, you are needed to design an “UmBasketella” with maximum volume. Suppose that “UmBasketella” is a cone-shape container and its surface area (include the bottom) is known, could you find the maximum value of the cone?

Input

Input contains several test cases. Eash case contains only one real number S, representing the surface area of the cone. It is guaranteed that 1≤S≤10000.

Output

For each test case, output should contain three lines.
The first line should have a real number representing the maximum volume of the cone.
Output the height of the cone on the second line and the radius of the bottom area of the cone on the third line.
All real numbers should rounded to 0.01.

Sample Input

30

Sample Output

10.93
4.37
1.55


题意:


已知一个圆锥的表面积(底面积+侧面积),求出这个圆锥的最大体积,高和底面半径。

解题思路:

圆锥面积: S=r2+lrπh=(l2r2)
圆锥体积: V=r2hπ

三分底面半径 r ,下界为一个小的正数,上界为圆锥的高为0时的半径rmax=S/(2r2π)


Code:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
using namespace std;


const double EPS=1e-6;
const double pi=acos(-1.0);

double v;
double vol(double r)
{
    double sc=v-pi*r*r;
    double l=sc/pi/r;
    double h=sqrt(l*l-r*r);
    return pi*r*r*h/3.0;
}

double getH(double r)
{
    double sc=v-pi*r*r;
    double l=sc/pi/r;
    return sqrt(l*l-r*r);
}


double ts()
{
    double lo=0.1,hi=sqrt(v/2.0/pi);
    double mid,mmid;
    while(hi-lo>EPS)
    {
        mid=(lo+hi)/2;
        mmid=(mid+hi)/2;
        if(vol(mid)>vol(mmid))
            hi=mmid;
        else
            lo=mid;
    }
    return lo;
}

int main()
{
    while( scanf("%lf",&v)!=EOF)
    {
        double low=ts();
        double H=getH(low);
        printf("%.2f\n",low*low*pi*H/3.0);
        printf("%.2f\n",H);
        printf("%.2f\n",low);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值