POJ 1068:Parencodings(模拟)

Radar Installation

Time limit:1000 ms Memory limit:10000 kB OS:Linux


Problem Description

Let S = s1 s2…s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2…pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2…wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S       (((()()())))

P-sequence      4 5 6666

W-sequence      1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9


题意:

有一串括号,根据括号生成两个序列:
P:从左到右,每个右括号之前的左括号数量。
W:从左到右,每个右括号匹配左括号,生成括号对中共包含的括号对数量。
现给出P串,求W串。

解题思路:

根据P串很容易还原出括号串,第一个数是4,说明第一个右括号前有4个左括号,第二个数是5,说明到上一个右括号前有5-4个左括号,依次类推,可以还原出括号串。
接着就是用栈来匹配括号了,很容易发现,中间包含多少个括号对,可以直接用左括号和右括号的下标来计算,因此,碰到左括号时,把其下标压入栈,碰到右括号时,出栈,由两个下标计算出结果。


Code:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <stack>

using namespace std;

int  a[25];
stack<int> s;
char str[100];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        int len=0,cnt=a[0];
        for(int i=0;i<n;i++)
        {
            if(i==0)
                cnt=a[0];
            else
                cnt=a[i]-a[i-1];
            for(int i=0;i<cnt;i++)
                str[len++]='(';
            str[len++]=')';
        }
        //str[len]='\0';
        //cout<<str<<endl;//此处已经还原出括号串
        for(int i=0;i<len;i++)
        {
            if(str[i]=='(')
                s.push(i);
            else
            {
                printf("%d",(i-s.top()+1)/2);
                if(i==len-1)
                    printf("\n");
                else
                    printf(" ");
                s.pop();
            }
        }
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值