POJ 3349:Snowflake Snow Snowflakes(Hash)

Snowflake Snow Snowflakes

Time limit:4000 ms Memory limit:65536 kB


Problem Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.

题意:

给出n个雪花六个花瓣的长度,判断是否有相同的两片雪花

解题思路:

我的方法比较蠢。。差点超时。
将每个雪花六个花瓣长度求和,在对一个数取余,生成一个哈希值。
再把下标存到哈希表中,每次判断的时候就在哈希值相同的雪花中找是否有相同的两片雪花。
判断的方法也很简单,起始位置0~5遍历一次,判断顺时针和逆时针中有没有完全一样的。


Code:

#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;

const int MAXV=99992;
const int maxn=100000+5;
int a[maxn][8];
vector<int> v[MAXV];

bool judge(int p,int q)
{
    for(int i=0; i<6; i++)
    {
        int flag=1;
        //顺时针
        for(int j=0; j<6; j++)
        {
            if(a[p][j]!=a[q][(i+j)%6])
            {
                flag=0;
                break;
            }
        }
        if(flag==1)
            return true;
        flag=1;
        //逆时针
        for(int j=0; j<6; j++)
        {
            if(a[p][j]!=a[q][(6-j+i)%6])
            {
                flag=0;
                break;
            }
        }
        if(flag==1)
            return true;
    }
    return false;
}

int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0; i<n; i++)
    {
        int sum=0;
        for(int j=0; j<6; j++)
        {
            scanf("%d",&a[i][j]);
            sum+=a[i][j];
        }
        sum%=MAXV;
        for(int j=0; j<v[sum].size(); j++)
        {
            if(judge(v[sum][j],i))
            {
                printf("Twin snowflakes found.\n");
                return 0;
            }
        }
        v[sum].push_back(i);
    }
    printf("No two snowflakes are alike.\n");
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值