1138 Postorder Traversal 甲级 xp_xht123

Suppose that all the keys in a binary tree are distinct positive integers. Given the preorder and inorder traversal sequences, you are supposed to output the first number of the postorder traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the first number of the postorder traversal sequence of the corresponding binary tree.

Sample Input:

7
1 2 3 4 5 6 7
2 3 1 5 4 7 6

Sample Output:

3

解题思路:题目给定前序遍历和中序遍历,建树,最后进行后序遍历

这题真的没什么可以说的就直接写就行

以下是代码:

#include<iostream>
#include<map>

using namespace std;
const int N = 1e5 + 10;
struct Node
{
    int val;
    Node*right = NULL ,*left = NULL;
};

int perorder[N] , inorder[N];
map<int,int>mp;

Node*build(int il , int ir , int pl , int pr)
{
    if(il > ir) return NULL;
    Node *root = new Node;
    root -> val = perorder[pl];
    int k = mp[root -> val];
    root -> left = build(il , k - 1 , pl + 1 , pl - il + k);
    root -> right = build(k + 1 , ir , pr - ir + k + 1 , pr);
    return root;
}

bool flag = true;

void dfs(Node *r)
{
    if(r == NULL) return ;
    dfs(r -> left);
    dfs(r -> right);
    if(flag)
    {
        cout<<r -> val;
        flag = false;
    }
}

int n;
int main()
{
    cin>>n;
    for(int i = 0;i < n;i ++) cin>>perorder[i];
    for(int i = 0;i < n;i ++)
    {
        cin>>inorder[i];
        mp[inorder[i]] = i;
    }
    
    Node *root = build(0 , n - 1 , 0 , n - 1);
    
    dfs(root);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值