POJ 1611 The Suspects

题目描述:

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1

  

/*题意:
 * n个学生,m个小组,一个学生可以参加多个小组;现规定0号学生为嫌疑人;
 * 每一组中如果有一个嫌疑人,则认定全组都为嫌疑人;计算共有多少嫌疑人;
  */
/*思路:
 *  并查集模板
 *  将每组的第一个学生与后面每一个学生合并,即归为一个集合,最后求与0号元素拥有共同祖先的元素个数
 * */
import java.util.Arrays;
import java.util.Scanner;
public class the_suspects {
    static int n,m;
    static int f[]=new int[30005];
    static void init(int n){
    	for(int i=0;i<n;i++)
    		f[i]=i;
    }
    static int find(int x){
    	if(f[x]==x)return x;
    	else
    		return f[x]=find(f[x]);
    }
    static void union(int x,int y){
    	int t1=find(x);
    	int t2=find(y);
    	if(t1!=t2)
    		f[t2]=t1;
    	return;
    }
	public static void main(String[] args) {
		// TODO Auto-generated method stub
     Scanner scan=new Scanner(System.in);
     while(scan.hasNext()){
    	 int ans=0;
    	 n=scan.nextInt();
    	 m=scan.nextInt();
    	 if(n==0 && m==0)break;
    	 init(n); //初始化啊啊啊~~~
    	 for(int i=0;i<m;i++){
    	     int k=scan.nextInt();
    	     int x,y;
    	     x=scan.nextInt(); //第一个数
    	     for(int j=1;j<k;j++){
    	    	 y=scan.nextInt();//后面的数
    	    	 union(x,y); //将第一个数与后面每个数合并
    	     }
    	 }
    	 for(int i=0;i<n;i++){    //注意学生编号从0到n-1
    		 if(find(i)==find(0)) ans++;   //找出所有与0号具有相同父结点的点
    	 }
    	 System.out.println(ans);
     }
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值