2021-07-08

r5

<Huawei>  
<Huawei>system-view 
Enter system view, return user view with Ctrl+Z.
[Huawei]sysname r5
[r5]
[r5]interface Serial 3/0/0
[r5-Serial3/0/0]ip add 15.1.1.2 24

[r5]aaa
[r5-aaa]local-user xiang password cipher 12345
Info: Add a new user.
[r5-aaa]local-user xiang service-type ppp

(5--1)

[r5]interface Serial 3/0/0  
[r5-Serial3/0/0]ppp authentication-mode pap 
[r5-Serial3/0/0]

(5--2)

[r5]interface Serial 3/0/1
[r5-Serial3/0/1]ppp authentication-mode chap 
[r5-Serial3/0/1]ip add 25.1.1.2 24

(5--3)
[r5]interface Serial 4/0/0
[r5-Serial4/0/0]link-protocol hdlc 
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]
:y
[r5-Serial4/0/0]ip add 35.1.1.2 24

(5--4)

[r5]int g 0/0/0
[r5-GigabitEthernet0/0/0]ip add 45.1.1.2 24
[r5-GigabitEthernet0/0/0]int lo0
[r5-LoopBack0]ip add 5.5.5.5 25

r1

<Huawei>   
<Huawei>system-view 
Enter system view, return user view with Ctrl+Z.  
[Huawei]sysname r1
[r1]
[r1]interface Serial 4/0/0
[r1-Serial4/0/0]ppp pap local-user xiang password cipher 12345

私网

[r1]int g 0/0/2
[r1-GigabitEthernet0/0/2]ip add 192.168.1.1 24


[r1]ip route-static 0.0.0.0 0 15.1.1.2


[r1]interface Tunnel 0/0/0
[r1-Tunnel0/0/0]ip add 10.1.1.1 24   
[r1-Tunnel0/0/0]tunnel-protocol gre 
[r1-Tunnel0/0/0]source 15.1.1.1
[r1-Tunnel0/0/0]destination 45.1.1.1


[r1]interface Tunnel 0/0/1
[r1-Tunnel0/0/1]ip add 10.1.2.1 24
[r1-Tunnel0/0/1]tunnel-protocol gre p2mp 
[r1-Tunnel0/0/1]source 15.1.1.1
[r1-Tunnel0/0/1]nhrp entry multicast dynamic 
[r1-Tunnel0/0/1]nhrp network-id 100

    
[r1]rip 1
[r1-rip-1]ver 2 
[r1-rip-1]un summary  
[r1-rip-1]network 192.168.1.0 
[r1-rip-1]network 10.0.0.0

[r1]acl 2000 
[r1-acl-basic-2000]rule permit source 192.168.1.0 0.0.0.255
[r1-acl-basic-2000]int s 4/0/0
[r1-Serial4/0/0]nat outbound 2000

 

r2
[r2]interface Serial 4/0/0
[r2-Serial4/0/0]ip address 25.1.1.1 24   
[r2-Serial4/0/0]ppp chap user xiang 
[r2-Serial4/0/0]ppp chap password cipher 12345

私网

[r2]int g 0/0/2
[r2-GigabitEthernet0/0/2]ip add 192.168.2.1 24

 
[r2]ip route-static 0.0.0.0 0 25.1.1.2


[r2]interface Tunnel 0/0/0
[r2-Tunnel0/0/0]ip add 10.1.2.2 24
[r2-Tunnel0/0/0]tunnel-protocol gre p2mp 
[r2-Tunnel0/0/0]source Serial 4/0/0
[r2-Tunnel0/0/0]nhrp entry 10.1.2.1 15.1.1.1 register 
[r2-Tunnel0/0/0]nhrp network-id 100

[r2]rip 1
[r2-rip-1]ver 2
[r2-rip-1]un summary 
[r2-rip-1]network 192.168.2.0
[r2-rip-1]network 10.0.0.0

[r2]acl 2000
[r2-acl-basic-2000]rule permit source 192.168.2.0 0.0.0.255
[r2-acl-basic-2000]int s 4/0/0
[r2-Serial4/0/0]nat outbound 2000
 

r3
[r3]interface Serial 4/0/0
[r3-Serial4/0/0]link-protocol hdlc 
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]
:y

私网

[r3]int g 0/0/2
[r3-GigabitEthernet0/0/2]ip add 192.168.3.1 24

[r3]ip route-static 0.0.0.0 0 35.1.1.2


[r3]interface Tunnel 0/0/0
[r3-Tunnel0/0/0]ip add 10.1.2.3 24
[r3-Tunnel0/0/0]tunnel-protocol gre p2mp 
[r3-Tunnel0/0/0]source Serial 4/0/0
[r3-Tunnel0/0/0]nhrp entry 10.1.2.1 15.1.1.1 register 
[r3-Tunnel0/0/0]nhrp network-id 100

[r3]rip 1
[r3-rip-1]ver 2   
[r3-rip-1]un summary 
[r3-rip-1]network 192.168.3.0
[r3-rip-1]network 10.0.0.0

[r3]acl 2000
[r3-acl-basic-2000]rule permit source 192.168.3.0 0.0.0.255
[r3-acl-basic-2000]int s 4/0/0
[r3-Serial4/0/0]nat outbound 2000
 

r4
[r4]int    
[r4]interface g 0/0/0
[r4-GigabitEthernet0/0/0]ip add 45.1.1.1 24
私网

[r4]int g 0/0/2
[r4-GigabitEthernet0/0/2]ip add 192.168.4.1 24

[r4]ip route-static 0.0.0.0 0 45.1.1.2


[r4]interface Tunnel 0/0/0
[r4-Tunnel0/0/0]ip add 10.1.1.2 24
[r4-Tunnel0/0/0]tunnel-protocol gre 
[r4-Tunnel0/0/0]source 45.1.1.1
[r4-Tunnel0/0/0]destination 15.1.1.1

[r4]rip 1
[r4-rip-1]ver 2
[r4-rip-1]un summary 
[r4-rip-1]network 192.168.4.0
[r4-rip-1]network 10.0.0.0

[r4]acl 2000
[r4-acl-basic-2000]rule permit source 192.168.4.0 0.0.0.255
[r4-acl-basic-2000]int g 0/0/0
[r4-Serial4/0/0]nat outbound 2000

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值