Factorial

Factorial

The most important part of a GSM network is so called Base Transceiver
Station (BTS). These transceivers form the areas called cells (this
term gave the name to the cellular phone) and every phone connects to
the BTS with the strongest signal (in a little simplified view). Of
course, BTSes need some attention and technicians need to check their
function periodically. ACM technicians faced a very interesting
problem recently. Given a set of BTSes to visit, they needed to find
the shortest path to visit all of the given points and return back to
the central company building. Programmers have spent several months
studying this problem but with no results. They were unable to find
the solution fast enough. After a long time, one of the programmers
found this problem in a conference article. Unfortunately, he found
that the problem is so called “Travelling Salesman Problem” and it is
very hard to solve. If we have N BTSes to be visited, we can visit
them in any order, giving us N! possibilities to examine. The function
expressing that number is called factorial and can be computed as a
product 1.2.3.4…N. The number is very high even for a relatively
small N.

The programmers understood they had no chance to solve the problem.
But because they have already received the research grant from the
government, they needed to continue with their studies and produce at
least some results. So they started to study behaviour of the
factorial function.

For example, they defined the function Z. For any positive integer N,
Z(N) is the number of zeros at the end of the decimal form of number
N!. They noticed that this function never decreases. If we have two
numbers N1<N2, then Z(N1) <= Z(N2). It is because we can never “lose”
any trailing zero by multiplying by any positive number. We can only
get new and new zeros. The function Z is very interesting, so we need
a computer program that can determine its value efficiently.

题目巴拉巴拉一大串,总结一句话就是求阶乘中尾数0的个数。例如5!=120,末尾有1个0则输出1,4!=24,末尾无0,则输出0。

Input

There is a single positive integer T on the first line of input. It stands for the number of numbers to follow. Then there is T lines, each containing exactly one positive integer number N, 1 <= N <= 1000000000.

Output

For every number N, output a single line containing the single non-negative integer Z(N).

Sample Input

6
3
60
100
1024
23456
8735373

Sample Output

0
14
24
253
5861
2183837

题解

由于题目要求输入的数字较大,无法直接求出阶乘再计算末尾0的个数。需要通过别的方法进行取巧。先进行分析N!末尾0的来源,发现0只能通过5和偶数相乘得到,且阶乘N!中偶数个数肯定比5的个数多,故求出N!因子中5的个数即可得到末尾0的个数即可。

源代码

#include <iostream>
using namespace std;
int main()
{
    int T;
    long N,NUM;//num为尾数0的个数
    cin>>T;
    while(T--)
    {
        cin>>N;
        NUM=0;
        while(N>=5)//求出5的个数
        {
            N/=5;
            NUM+=N;
        }
        cout<<NUM<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

椰子zii

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值