【PAT】A1028 List Sorting

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​) and C, where N is the number of records and C is the column that you are supposed to sort the recor1028 List Sortingds with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

解题思路:

  1. 理解题意:给出一组数据,根据第一行给出的两个数,第一个数表示有多少行数据,第二个数是按多少列排序
  2. 本段代码分为3段:首先,根据题意输入数据,其次,根据题意用不同的排序函数排序;最后输出数据
  3. 总结:本题十分简单,理解即可,只要根据不同的要求做不同的排序即可

代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
struct stu{
	int id;
	char name[9];
	int grade;
}s[100010];

bool cmp1(stu a,stu b){	
	return a.id<b.id;
}
bool cmp2(stu a,stu b){
	int s= strcmp(a.name,b.name);
	if(s!=0) return s<0;
	else return a.id<b.id;
}

bool cmp3(stu a,stu b){
	if(a.grade!=b.grade) return a.grade<b.grade;
	else return a.id<b.id;
}
int main(){
	int N,C;
	scanf("%d%d",&N,&C);
	for(int i=0;i<N;i++){
		scanf("%d",&s[i].id);
		scanf("%s %d",s[i].name,&s[i].grade);
	}
	if(C==1) sort(s,s+N,cmp1);
	else if(C==2) sort(s,s+N,cmp2);
	else sort(s,s+N,cmp3);
	for(int i=0;i<N;i++){
		printf("%06d %s %d\n",s[i].id,s[i].name,s[i].grade);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_之桐_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值