Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.
First the playing order is randomly decided for NP programmers. Then every NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NG winners are then grouped in the next match until a final winner is determined.
For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: NP and NG (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NP distinct non-negative numbers Wi (i=0,⋯,NP−1) where each Wi is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,NP−1 (assume that the programmers are numbered from 0 to NP−1). All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.
Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3
Sample Output:
5 5 5 2 5 5 5 3 1 3 5
解题思路:
- 理解题意:略
- 思路:生成一个数组,求得当前状况下的组数,在每组循环内,第一要判断边界,第二要以编号为代表的老鼠的体重的比较,每组体重最大的老鼠的编号重新进队列。最后输出
- 总结:这道题卡了好久,翻书做出来的。也就是说如果在考场上这道题就可以让我挂掉了。有点丧。真的很难吗,队列,其实也不见得很难,但是为什么没做出来,花了那么长时间,走了弯路呢。在总结这里,我认为,逻辑不够理清,谋定而后动落实的不够完全,算法思想没有得到很好的应用(本题其实可以使用映射的思想,通过老鼠的标号映射老鼠的体重)。其实用编号我已经想到了,但是走着走着,步调、思路就乱了,没有很好贯彻下去,后来变成了体重求解了,另外分组也是,把问题复杂化了,没有统一和归并(比如最后解出来是用一组group和n的循环,但是一开始我分了while(x--)和while(r--)符合n的满的一组和不满的分开这样就乱掉了)。需要吸取教训。
代码:
#include <stdio.h>
#include <queue>
#include <algorithm>
using namespace std;
queue<int> q;
struct mice1{
int weight,rank;
}mice[1010];
/*
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3
*/
int main(){
int m,n,k; //m表示一共有多少只老鼠,n表示多少只老鼠分为一组,k表示位置
scanf("%d%d",&m,&n);
for(int i=0;i<m;i++){
scanf("%d",&mice[i].weight);
}
for(int i=0;i<m;i++){ //队列中的位置
scanf("%d",&k);
q.push(k); //标号入读
}
int count=1; //轮数
int group,x=m; //队数和老鼠的总数
while(q.size()!=1){
if(x%n==0) group=x/n;
else group=x/n+1;
for(int i=0;i<group;i++){
int max=q.front();//存放最大值的编号
for(int j=0;j<n;j++){
if(i*n+j>=x) break; //在最后一组老鼠数不足n是起作用,跳出循环
int front=q.front(); //队首老鼠的编号
if(mice[front].weight>mice[max].weight)
max=front;
mice[front].rank=group+1;
q.pop();
}
q.push(max);
}
x=group; // 几队就有几只老鼠,回代老鼠数量
}
mice[q.front()].rank=1;
for(int i=0;i<m;i++){
printf("%d",mice[i].rank);
if(i<m-1) printf(" ");
}
return 0;
}