【PAT】A1102 Invert a Binary Tree

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

总结:

  1. 重复的不再这里累述,有点问题的是对静态树缺乏使用的经验,另外对反转树理解不是很透彻
  2. 用后序序列反转列表优于先序序列
  3. scanf("%*c");可以在scanf中接收一个字符,在本题中吃掉上一行的换行符,否则%c会被输入换行符,这个要注意,也可以用getchar()吃掉换行符。在用%c输入的时候尤其要注意换行符不能被插入

代码:

#include <stdio.h>
#include <queue>
using namespace std;
const int maxn=110;
int total;
bool  check[maxn]={false};
struct Node{
	int lchild;
	int rchild;
}node[maxn];

int strTonum(char c){  //字符转化为数组 
	if(c=='-') return -1;
	else{
		check[c-'0']=true;
		return c-'0';
	}
}

int foundRoot(){  //找到根结点 
	for(int i=0;i<total;i++){
		if(check[i]==false) return i;
	}
}


int num=0; //当前输出的个数 
void print(int x){  //输出 
	printf("%d",x);
	num++;
	if(num<total) printf(" ");
	else printf("\n");
}
void BFS(int root){  //层序遍历 
	queue<int> q;
	q.push(root);
	while(!q.empty()){
		int x=q.front();
		q.pop();
		print(x);
		if(node[x].lchild!=-1) q.push(node[x].lchild);
		if(node[x].rchild!=-1) q.push(node[x].rchild);
	}
}
void inOrder(int root){  //中序遍历 
	if(root==-1) return;
	inOrder(node[root].lchild);
	print(root);
	inOrder(node[root].rchild);
}
void postOrder(int root){  //后序遍历用于反转二叉树 
	if(root==-1) return;
	postOrder(node[root].lchild);
	postOrder(node[root].rchild);
	swap(node[root].lchild,node[root].rchild);  //交换左右孩子结点 
}  

int main(){
	scanf("%d",&total);
	char lchild,rchild;
	for(int i=0;i<total;i++){
		scanf("%*c%c %c",&lchild,&rchild);  //%*c吃掉上一行的换行符 ,因为%c也会把空格输入 
		node[i].lchild=strTonum(lchild);
		node[i].rchild=strTonum(rchild);
	}
	int root=foundRoot();
	postOrder(root);  //后序遍历反转二叉树 
	BFS(root); 
	num=0;
	inOrder(root);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_之桐_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值