【PAT】A1066 Root of AVL Tree ***

 

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

 

 

 

 

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

 

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

总结:

  1. 平衡二叉树模块,背吧:①创建结构体——②生成一个新结点(node* newNode(int v))——③获得以root为根的高度height(int getHeight(node* root))——④更新结点的高度(void updateHeight(node* root))——⑤计算平衡因子(int getBalanceFactor(node* root))——⑥左旋(void L(node* &root))、右旋(void R(node* &root))——⑦插入权值为v的结点(v比根权值小,LL2,1,LR2,-1型,v比根权值大,RR-2,-1,RL-2,1型)(void insert(node* &root,int v))——⑧AVL树的创建(node* Create(int data[],int n))—— ⑨主函数

代码: 

#include <stdio.h>
#include <algorithm>
using namespace std;
struct node{
	int v;
	int height;
	node *lchild,*rchild;
} *root;

//生成一个新结点,v为结点权值
node* newNode(int v){
	node* Node = new node;
	Node->v=v;
	Node->height=1;
	Node->lchild=Node->rchild=NULL;
	return Node;
} 

//获取以root为根结点的子树当前的height
int getHeight(node* root){
	if(root==NULL) return 0;  //空结点高度是0 
	return root->height;
} 

//更新结点root的height
void updateHeight(node* root){
	//max(左孩子结点的height,右孩子结点的height)+1
	root->height=max(getHeight(root->lchild),getHeight(root->rchild))+1; 
} 

//计算结点的平衡因子
int getBalanceFactor(node* root){
	//左子树高度-右子树高度
	return getHeight(root->lchild)-getHeight(root->rchild);
} 

//左旋
void L(node* &root){
	node* temp=root->rchild;
	root->rchild=temp->lchild;
	temp->lchild=root;
	updateHeight(root);
	updateHeight(temp);
	root=temp;
} 

//右旋
void R(node* &root){
	node* temp=root->lchild;
	root->lchild=temp->rchild;
	temp->rchild=root;
	updateHeight(root);
	updateHeight(temp);
	root=temp;
} 

//插入权值为v的结点
void insert(node* &root,int v) {
	if(root==NULL){
		root=newNode(v);
		return;
	}
	if(v<root->v){  //v比根结点权值小 
		insert(root->lchild,v);
		updateHeight(root);
		if(getBalanceFactor(root)==2){
			if(getBalanceFactor(root->lchild)==1){  //LL型 
				R(root);   
			}
			else if(getBalanceFactor(root->lchild)==-1){  //LR型 
				L(root->lchild);
				R(root);
			}
		}
	}else{  //v比根结点权值大 
		insert(root->rchild,v);
		updateHeight(root);
		if(getBalanceFactor(root)==-2){
			if(getBalanceFactor(root->rchild)==-1){  //RR型 
			L(root); 
			}
			else if(getBalanceFactor(root->rchild)==1){  //RL型 
			R(root->rchild);
			L(root);
			} 
		}
	}
}

//AVL树的建立
node* Create(int data[],int n){
	node* root=NULL;
	for(int i=0;i<n;i++){
		insert(root,data[i]);   //插入AVL树 
	}
	return 0;
} 

int main(){
	int n,v;
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		scanf("%d",&v);
		insert(root,v);
	}
	printf("%d\n",root->v);
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_之桐_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值