POJ-1260 Pearls

Pearls
原题链接
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9776 Accepted: 5015
Description

In Pearlania everybody is fond of pearls. One company, called The Royal Pearl, produces a lot of jewelry with pearls in it. The Royal Pearl has its name because it delivers to the royal family of Pearlania. But it also produces bracelets and necklaces for ordinary people. Of course the quality of the pearls for these people is much lower then the quality of pearls for the royal family.In Pearlania pearls are separated into 100 different quality classes. A quality class is identified by the price for one single pearl in that quality class. This price is unique for that quality class and the price is always higher then the price for a pearl in a lower quality class.
Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain quality class one has to pay an extra amount of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl.
Also The Royal Pearl is suffering from the slow-down of the global economy. Therefore the company needs to be more efficient. The CFO (chief financial officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is actually needed.No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the
prices remain the same.
For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10+(100+10)*20 = 2350 Euro.Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro.
The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program.

Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested,or in a higher quality class, but not in a lower one.
Input

The first line of the input contains the number of test cases. Each test case starts with a line containing the number of categories c (1<=c<=100). Then, c lines follow, each with two numbers ai and pi. The first of these numbers is the number of pearls ai needed in a class (1 <= ai <= 1000).
The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending order. All numbers in the input are integers.
Output

For each test case a single line containing a single number: the lowest possible price needed to buy everything on the list.
Sample Input

2
2
100 1
100 2
3
1 10
1 11
100 12
Sample Output

330
1344
Source

Northwestern Europe 2002

珍珠
原题链接
时间限制: 1000MS 内存限制: 10000K
提交总数: 9776 接受: 5015
描述

在Pearlania,每个人都喜欢珍珠。一家名为The Royal Pearl的公司生产大量珍珠珠宝。皇家珍珠的名字是因为它传递给了Pearlania王室。但它也为普通人制作手镯和项链。当然,这些人的珍珠质量远低于皇室珍珠的质量。珍珠珍珠分为100个不同的质量等级。质量等级由该质量等级中的单颗珍珠的价格确定。这个价格对于那个质量等级来说是独一无二的,价格总是高于一个质量较低的类中的珍珠的价格。
每个月,皇家珍珠的库存经理都会准备一张清单,列出每个质量类别所需的珍珠数量。珍珠是在当地的珍珠市场上买到的。每个质量类别都有自己的珍珠价格,但是对于每个完整的交易,在一定的质量等级下,必须支付相当于该类别中十颗珍珠的额外金额。这是为了防止游客购买一颗珍珠。
此外,皇家明珠正受到全球经济放缓的困扰。因此,公司需要更高效。首席财务官(首席财务官)发现,他有时可以通过以高于实际需要的高质量级别购买珍珠来节省资金。没有客户会指责皇家珠宝将更好的珍珠放入手镯中,只要
价格保持不变相同。
例如10欧元类别需要5颗珍珠,20欧元类别需要100颗珍珠。这通常会花费:(5 + 10)* 10 +(100 + 10)* 20 = 2350欧元。购买20欧元类别的所有105颗珍珠只需花费:(5 + 100 + 10)* 20 = 2300欧元。
问题是,在首席财务官知道有多少珍珠能够在更高质量的类别中最好地购买之前,它需要大量的计算工作。你被要求用电脑程序帮助皇家珍珠。

给出一份珍珠数量和不同质量等级的珍珠每颗珍珠的价格清单,列出购买清单上所有物品所需的最低价格。珍珠可以按照要求购买,或者以更高质量的价格购买,但不能更低。
输入

输入的第一行包含测试用例的数量。每个测试用例都以包含类别数量c(1 <= c <= 100)的行开始。然后,c行跟随,每个都有两个数字ai和pi。这些数字中的第一个是班级需要的珍珠数量(1 <= ai <= 1000)。
第二个数字是该类别中每颗珍珠的价格(1 <= pi <= 1000)。类别的质量(以及价格)按升序排列。输入中的所有数字都是整数。
输出

对于每个测试案例,只有一行包含单个数字:购买列表中所有内容所需的最低价格。
示例输入

2
2
100 1
100 2
3
1 10
1 11
100 12
示例输出

330
1344
资源

西北欧洲2002年

代码

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=105;
int T,n,p[maxn],a[maxn],f[maxn];
int main()
{
    scanf("%d",&T);
    while (T--)
    {
        scanf("%d",&n);
        for (int i=1;i<=n;i++) scanf("%d%d",a+i,p+i);
        for (int i=1;i<=n;i++)
        {
            f[i]=p[i]*(a[i]+10)+f[i-1];
            for (int j=i-1,sum=a[i]+10,x;j;j--)
            {
                sum+=a[j];
                if ((x=f[j-1]+p[i]*sum)<f[i]) f[i]=x;
            }
        }
        printf("%d\n",f[n]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值