POJ-2531 Network Saboteur

22 篇文章 0 订阅
7 篇文章 0 订阅

Network Saboteur
题目链接
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 14018 Accepted: 6860
Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts.
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks.
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him.
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).
Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000).
Output file must contain a single integer – the maximum traffic between the subnetworks.
Output

Output must contain a single integer – the maximum traffic between the subnetworks.
Sample Input

3
0 50 30
50 0 40
30 40 0
Sample Output

90
Source

Northeastern Europe 2002, Far-Eastern Subregion

题目大意
给出n个点,两两之间存在代价(Cij表示i和j的代价),把这n个点分成两组,求ΣCij(其中i属于第一组,j属于第二组)

数据范围
2 <= N <= 20;0 <= Cij <= 10^4

题解
小题不太难。可以写 DFS,但是时间大概是是 2^20*400 ≈ 4*10^8 ,时间上限是 2 秒,这么写如果写得好一点基本就可以过了(我第一次就是这么写了个暴力就过了)。当然,我们可以加一道优化,让代码跑得更快。
我们的代码先假设一开始所有的点都在一组,然后我们枚举哪几个分到另一组。那么我们把某个点分过去,当且仅当分过去能产生更多的代价而不是使得代价减少。也就是在进行下一步 DFS 前,判一下代价是否降低了。
但是这样是否会有问题?我也有这个顾虑,但是证明不来x_x,所以写了一个对拍拍了很久都没有停。

代码

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=25;
int n,ans,a[maxn][maxn];
bool vis[maxn];
void dfs(int x,int s)
{
    vis[x]=true;
    int tem=s;
    for (int i=1;i<x;i++)
      if (vis[i]) tem-=a[x][i];else tem+=a[x][i];
    for (int i=x+1;i<=n;i++) tem+=a[x][i];
    //这两段循环,把同组的代价减去,不同组的代价加上以判断是否有必要继续DFS
    //不用担心多减
    if (ans<tem) ans=tem;
    if (tem>=s)
      for (int i=x+1;i<=n;i++) dfs(i,tem);
    vis[x]=false;
}
int main()
{
    scanf("%d",&n);
    for (int i=1;i<=n;i++)
     for (int j=1;j<=n;j++) scanf("%d",&a[i][j]);
    dfs(1,0);
    printf("%d",ans);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值