POJ 3126 Prime Path

题意大题是给你两个素数a,b,第一个素数a每次只能改变一位数字,求他最少改变几次能变成素数b,中间变化的过程全是素数。

结题思路就是素数筛+bfs求最少次数(每次改变一位数子穷举所有情况)。

Prime Path
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9555 Accepted: 5490

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>

using namespace std;

struct node
{
    int a;
    int step;
} q[10100];
bool f[10100];
int k[10100];
int x, y;
int sum;
int v[10100];
void prime()
{
    int i, j, t = 0;
    memset(f , false , sizeof(f));
    for(i = 2; i <= 10100; i++)
    {
        if(!f[i])
            k[t++] = i;
        for(j = 0; j < t; j++)
        {
            if(i*k[j] > 10100)
                break;
            f[i*k[j]] = true;
            if(i%k[j] == 0)
                break;
        }
    }
}

int bfs()
{
    struct node t;
    int i, l, r;
    l = r = 0;
    q[l].a = x;
    q[r++].step = 0;
    v[x] = 1;
    while(l < r)
    {
        t = q[l++];
        if(t.a == y)
        {
            sum = t.step;
            return 1;
        }
        int u = t.a%10;
        int d = (t.a/10)%10;
        for(i = 1; i <= 9; i+=2)
        {
            int y = (t.a/10)*10+i;
            if(y != t.a && !v[y] && !f[y])
            {
                v[y] = true;
                q[r].a = y;
                q[r++].step = t.step+1;
            }
        }
        for(i = 0; i <= 9; i++)
        {
            int y = (t.a/100)*100+i*10+u;
            if(y!=t.a && !v[y] && !f[y])
            {
                v[y] = 1;
                q[r].a = y;
                q[r++].step = t.step+1;
            }
        }
        for(i = 0; i <= 9; i++)
        {
            int y = (t.a/1000)*1000+i*100+d*10+u;
            if(y!=t.a && !v[y] && !f[y])
            {
                v[y] = 1;
                q[r].a = y;
                q[r++].step = t.step+1;
            }
        }
        for(i = 1; i <= 9; i++)
        {
            int y =i*1000 + t.a%1000;
            if(y!=t.a && !v[y] && !f[y])
            {
                v[y] = 1;
                
                q[r].a = y;
                q[r++].step = t.step+1;
            }
        }
    }
    return 0;
}

int main()
{
    int t;
    scanf("%d",&t);
    prime();
    while(t--)
    {
        scanf("%d%d",&x, &y);
        memset(v , 0 , sizeof(v));
        if(bfs())
            printf("%d\n",sum);
        else
            printf("Impossible\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值