POJ 3026 Borg Maze

在多数大神眼里这是一道水题啊、、但菜鸟伤不起啊、、好不容易看懂的英文又发现不太简单、、昨天写了一天的BFS竟然无情的错掉了啊、、吐槽一下昨天是情人节啊、、人家过情人节,屌丝却在敲代码,还老错啊、、伤不起啊。。。好了言归正传,这是一道最小生成树的题目,但是每天各点之间的权值没有给出啊,需要用BFS来求出啊、、自己的BFS老是出错啊、、就学习了pengge的啊、、算了,还得多加练习啊、、、菜鸟不能休息啊、、、

还有就是测试数据有问题,POJ的discuss里面有说的,大家做的时候可以看一下啊、、

Borg Maze
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7006 Accepted: 2362

Description

The Borg is an immensely powerful race of enhanced humanoids from the delta quadrant of the galaxy. The Borg collective is the term used to describe the group consciousness of the Borg civilization. Each Borg individual is linked to the collective by a sophisticated subspace network that insures each member is given constant supervision and guidance. 

Your task is to help the Borg (yes, really) by developing a program which helps the Borg to estimate the minimal cost of scanning a maze for the assimilation of aliens hiding in the maze, by moving in north, west, east, and south steps. The tricky thing is that the beginning of the search is conducted by a large group of over 100 individuals. Whenever an alien is assimilated, or at the beginning of the search, the group may split in two or more groups (but their consciousness is still collective.). The cost of searching a maze is definied as the total distance covered by all the groups involved in the search together. That is, if the original group walks five steps, then splits into two groups each walking three steps, the total distance is 11=5+3+3.

Input

On the first line of input there is one integer, N <= 50, giving the number of test cases in the input. Each test case starts with a line containg two integers x, y such that 1 <= x,y <= 50. After this, y lines follow, each which x characters. For each character, a space `` '' stands for an open space, a hash mark ``#'' stands for an obstructing wall, the capital letter ``A'' stand for an alien, and the capital letter ``S'' stands for the start of the search. The perimeter of the maze is always closed, i.e., there is no way to get out from the coordinate of the ``S''. At most 100 aliens are present in the maze, and everyone is reachable.

Output

For every test case, output one line containing the minimal cost of a succesful search of the maze leaving no aliens alive.

Sample Input

2
6 5
##### 
#A#A##
# # A#
#S  ##
##### 
7 7
#####  
#AAA###
#    A#
# S ###
#     #
#AAA###
#####  

Sample Output

8
11
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#define oo 1 << 30


using namespace std;

int a[100][100],b[120][120];
int c[120][4],d[120];
bool v[120];
int status[120][120],queue[100000][2];
int vex[]= {-1,1,0,0};
int vey[]= {0,0,-1,1};
int n,m,s;
string s1;


int prim()
{
    int n = s-1;
    memset(v , false , sizeof(v));
    int sum = 0;
    for(int i = 1; i <= n; i++) d[i] = b[1][i];
    d[1] = 0;
    v[1] = true;
    for(int i = 1; i <= n-1; i++)
    {
        int x, m = oo;
        for(int y = 1; y <= n; y++) if(!v[y] && d[y]<=m) m = d[x=y];
        sum += m;
        v[x] = true;
        for(int y = 1; y <= n; y++) if(!v[y] && d[y] > b[x][y]) d[y] = b[x][y];
    }
    return sum;
}



void bfs(int x, int y)
{
    int i, base, top, posx, posy;
    int xend, yend, sum[120][120];
    posx = x;
    posy = y;
    memset(status , 0 , sizeof(status));
    memset(sum , 0 , sizeof(sum));
    base = top = 0;
    queue[top][0] = x;
    queue[top++][1] = y;
    status[x][y] = 1;
    while(base < top)
    {
        x = queue[base][0];
        y = queue[base++][1];
        for(i = 0; i <= 3; i++)
        {
            xend = x+vex[i];
            yend = y+vey[i];
            if(xend >= 1 && xend <= n && yend >= 1 && yend <= m && !status[xend][yend] && a[xend][yend]!=0)
            {
                sum[xend][yend] = sum[x][y]+1;
                if(a[xend][yend] != -1)
                {
                    b[a[posx][posy]][a[xend][yend]]=sum[xend][yend];
                    b[a[xend][yend]][a[posx][posy]]=sum[xend][yend];
                }
                queue[top][0] = xend;
                queue[top++][1] = yend;
                status[xend][yend] = 1;
            }
        }
    }
}


int main()
{
    int i, j, t;
    char d, str[100];
    cin >>t;
    while(t--)
    {
        cin >>m>>n;
        gets(str);
        s = 2;
        for(i = 1; i <= n; i++)
        {
            for(j = 1; j <= m; j++)
            {
                d=cin.get();
                if(d == '#')
                    a[i][j] = 0;
                else if(d == 'A')
                {
                    a[i][j] = s;
                    c[s][0] = i;
                    c[s][1] = j;
                    s++;
                }
                else if(d == 'S')
                {
                    a[i][j] = 1;
                    c[1][0] = i;
                    c[1][1] = j;
                }
                else if(d == ' ')
                    a[i][j] = -1;
            }
            cin.get();
        }
        for(i = 1; i <= s-1; i++)
            bfs(c[i][0], c[i][1]);
        for(i = 1; i < s-1; i++)
            for(j = 1; j <= s-1; j++)
                if(i == j)
                    b[i][j] = 0;
        printf("%d\n",prim());
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值