POJ 2531 Network Saboteur

题目大意:

把一个完全图分成两部分,使得连接这两部分边的权和最大。

结题思路是暴力枚举任意集合的划分,找到最大的值。

举例说明:

3
0 50 30
50 0 40
30 40 0

先将第一行的数字加起来得到一个和sum = 80,在把第二行中出现的减去,就是50(1,2)和(2,1)是一回事。没有出现的在加起来,得到sum = 70就是1,2是一个集合3是单独的一个集合的值,在将1,2划分到一个集合,就是减去30,再加上40,sum = 90;更新最大值。接着找2,3是一个集合、、

因此要用到递归调用、、

Network Saboteur
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8394 Accepted: 3871

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts. 
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks. 
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him. 
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000). 
Output file must contain a single integer -- the maximum traffic between the subnetworks. 

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90
#include <stdio.h>
#include <string.h>
#include <iostream>

using namespace std;

int dp[105][105], n, _max, sum;
int v[105][105];

void dfs(int x)
{
    if(x > n)
        return ;
    for(int i = 1; i <= n; i++)
    {
        if(!v[x][i] && dp[x][i])
        {
            sum += dp[x][i];
            v[i][x] = 1;
        }
        else if(v[x][i] && dp[x][i])
        {
            sum -= dp[x][i];
            v[i][x] = 1;
        }
    }
    if(sum > _max)
        _max = sum;
    for(int i = x+1; i <= n; i++)
        dfs(i);
    for(int i = 1; i <= n; i++)
    {
        if(!v[x][i] && dp[x][i])
        {
            sum -= dp[x][i];
            v[i][x] = 0;
        }
        else if(v[x][i] && dp[x][i])
        {
            sum += dp[x][i];
            v[i][x] = 0;
        }
    }
}

int main()
{
    int i, j;
    while(~scanf("%d",&n))
    {
        memset(v , 0 , sizeof(v));
        for(i = 1; i <= n; i++)
            for(j = 1; j <= n; j++)
                cin >>dp[i][j];
        sum = 0;
        _max = 0;
        for(i = 1; i <= n; i++)
            dfs(i);
        printf("%d\n",_max);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值