POJ 1905 Expanding Rods

首先说一下题意:就是给你一个棒子,它会热胀冷缩。如果温度升高它会变长,但是他被卡在墙中只能变弯、、要求求出变弯后升高的高度。

伸长的公式是:l` = l*(1+n*c),l是原长,n是温度变化的范围,c是变化的系数。

主要是理解题意找到关系式,然后枚举高度。。。

关系式有;

1,s/2 = θ*r; 2, sinθ = L/(2*r); 3,r^2 = (r-h)^2+(L/2)^2;

可以得到:1, r = (4*h^2+L^2)/(8*h); 2, s = 2*r*arcsin(L/(2*r));

二分枚举h,通过判断s是否满足条件来确定边界。

Ps:以前受崔老师的影响一开始想到的是枚举角度,但是在这里有点行不通的啊、、、

Expanding Rods
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 10288 Accepted: 2616

Description

When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion.
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment. 

Your task is to compute the distance by which the center of the rod is displaced. 

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.

Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision. 

Sample Input

1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output

61.329
225.020
0.000
#include <iomanip>
#include <stdlib.h>
#include <stdio.h>
#include <string>
#include <string.h>
#include <iostream>
#include <cmath>
const double esp=1e-5;

using namespace std;

int main()
{
    double l, ll, c, n;
    while(cin >>l>>n>>c)
    {
        if(l == -1 && n == -1 && c == -1)
            break;
        ll = l*(1 + n*c)*1.0;
        double low = 0.0;
        double hight = 0.5*l;
        double mid = 0;
        while(hight-low > esp)
        {
            mid = (hight+low)/2;
            double r = (4*mid*mid + l*l)/(8*mid);
            if(2*r*asin(l/(2*r)) < ll)
                low = mid;
            else
                hight = mid;
        }
        cout <<fixed<<setprecision(3)<<mid<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值