POJ 3070 Fibonacci(需要继续学习)

构造矩阵与矩阵的快速幂取模。。。宝哥给讲的算法原理,代码是学的别人的,先写一下回头还得再研究。

Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8121 Accepted: 5774

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-7
#define M 100100
#define LL __int64
#define INF 0x3f3f3f3f
#define PI 3.1415926535898


using namespace std;

struct node
{
    int dp[2][2];
};
node ad;
int n, mod;

node mul(node a, node b)
{
    node t;
    int i, j, k;
    memset(t.dp, 0 , sizeof(t.dp));
    for(i = 0; i < 2; i++)
    {
        for(k = 0; k < 2; k++)
        {
            if(a.dp[i][k])
            {
                for(j = 0; j < 2; j++)
                {
                    t.dp[i][j] += a.dp[i][k]*b.dp[k][j];
                    if(t.dp[i][j] > mod)
                        t.dp[i][j] %= mod;
                }
            }
        }
    }
    return t;
}

node expo(node p, int k)
{
    if(k == 1) return p;
    node e;
    int i;
    memset(e.dp , 0 , sizeof(e.dp));
    for(i = 0; i < n; i++) e.dp[i][i] = 1;
    if(k == 0)
        return e;
    while(k)
    {
        if(k&1) e = mul(p,e);
        p = mul(p, p);
        k >>= 1;
    }
    return e;
}

int main()
{
    n = 2;
    mod = 10000;
    int k;
    ad.dp[1][1] = 0;
    ad.dp[0][1] = ad.dp[1][0] = ad.dp[0][0] = 1;
    while(cin >>k)
    {
        if(k == -1)
            break;
        node t = expo(ad, k);
        int ans = t.dp[0][1]%mod;
        cout <<ans<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值