POJ 1925 Spiderman(线性dp)

126 篇文章 2 订阅
46 篇文章 0 订阅

题意很好懂就是蜘蛛侠去救人,开始在自己的apartment里,需要赶到west tower里。途中有许多building。给出每一个building的位置和高度。spiderman可以涂丝挂到某个building的顶端,然后swing,就像荡秋千一样。求spiderman最少要荡多少次。一开始的时候不理解为什么可以荡过比它高的building,后来一想他完全可以绕过去啊。所以这里的重点是他每次到达的点都是起点的对称位置。

用坐标但作为dp的值,但是一开始就是找不到可以到达的条件,各种蛋疼,无奈啊、、、后来才发现原来条件是得构成一个直角三角形,否则是不可能到达的啊。sad、、这样就解决了怎么过来的问题了啊,直接就可以dp了啊。

x表示枚举的点到building[i]的距离,y表示building[i]与building[0]的高度差,z表示building[i]的高度。这样的的话,如果能荡过来的话那条斜边的长度z^2 = x^2+y^2。z就是那条斜边啊、、sad,怎么一开始没发现啊、、

Spiderman
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 6091 Accepted: 1195

Description

Dr. Octopus kidnapped Spiderman's girlfriend M.J. and kept her in the West Tower. Now the hero, Spiderman, has to reach the tower as soon as he can to rescue her, using his own weapon, the web. 

From Spiderman's apartment, where he starts, to the tower there is a straight road. Alongside of the road stand many tall buildings, which are definitely taller or equal to his apartment. Spiderman can shoot his web to the top of any building between the tower and himself (including the tower), and then swing to the other side of the building. At the moment he finishes the swing, he can shoot his web to another building and make another swing until he gets to the west tower. Figure-1 shows how Spiderman gets to the tower from the top of his apartment – he swings from A to B, from B to C, and from C to the tower. All the buildings (including the tower) are treated as straight lines, and during his swings he can't hit the ground, which means the length of the web is shorter or equal to the height of the building. Notice that during Spiderman's swings, he can never go backwards. 

You may assume that each swing takes a unit of time. As in Figure-1, Spiderman used 3 swings to reach the tower, and you can easily find out that there is no better way.

Input

The first line of the input contains the number of test cases K (1 <= K <= 20). Each case starts with a line containing a single integer N (2 <= N <= 5000), the number of buildings (including the apartment and the tower). N lines follow and each line contains two integers Xi, Yi, (0 <= Xi, Yi <= 1000000) the position and height of the building. The first building is always the apartment and the last one is always the tower. The input is sorted by Xi value in ascending order and no two buildings have the same X value.

Output

For each test case, output one line containing the minimum number of swings (if it's possible to reach the tower) or -1 if Spiderman can't reach the tower.

Sample Input

2
6
0 3
3 5
4 3
5 5
7 4
10 4
3
0 3
3 4
10 4

Sample Output

3
-1
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-8
#define M 1000100
//#define LL __int64
#define LL long long
#define INF 0x7ffffff
#define PI 3.1415926535898


const int maxn = 1000010;

using namespace std;

int dp[maxn];
struct node
{
    int x, y;
} f[maxn];

int main()
{
    int T;
    cin >>T;
    while(T--)
    {
        int n;
        cin >>n;
        for(int i = 0; i < n; i++)
            scanf("%d %d", &f[i].x, &f[i].y);
        int m = f[n-1].x;
        for(int i = 0; i <= m; i++)
            dp[i] = INF;
        dp[0] = 0;
        for(int i = 1; i < n; i++)
        {
            LL z = f[i].y;
            LL y = f[i].y-f[0].y;
            for(int j = f[i].x-1; j >= f[0].x; j--)
            {
                LL x = f[i].x-j;
                if(z*z < x*x+y*y)
                    break;
                int s = f[i].x+x;
                if(s > m)
                    s = m;
                dp[s] = min(dp[s], dp[j]+1);
            }
        }
        if(dp[m] == INF)
            cout<<"-1"<<endl;
        else
            cout<<dp[m]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值