poj 1925 Spiderman

Spiderman
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 7080 Accepted: 1420

Description

Dr. Octopus kidnapped Spiderman's girlfriend M.J. and kept her in the West Tower. Now the hero, Spiderman, has to reach the tower as soon as he can to rescue her, using his own weapon, the web. 

From Spiderman's apartment, where he starts, to the tower there is a straight road. Alongside of the road stand many tall buildings, which are definitely taller or equal to his apartment. Spiderman can shoot his web to the top of any building between the tower and himself (including the tower), and then swing to the other side of the building. At the moment he finishes the swing, he can shoot his web to another building and make another swing until he gets to the west tower. Figure-1 shows how Spiderman gets to the tower from the top of his apartment – he swings from A to B, from B to C, and from C to the tower. All the buildings (including the tower) are treated as straight lines, and during his swings he can't hit the ground, which means the length of the web is shorter or equal to the height of the building. Notice that during Spiderman's swings, he can never go backwards. 

You may assume that each swing takes a unit of time. As in Figure-1, Spiderman used 3 swings to reach the tower, and you can easily find out that there is no better way.

Input

The first line of the input contains the number of test cases K (1 <= K <= 20). Each case starts with a line containing a single integer N (2 <= N <= 5000), the number of buildings (including the apartment and the tower). N lines follow and each line contains two integers Xi, Yi, (0 <= Xi, Yi <= 1000000) the position and height of the building. The first building is always the apartment and the last one is always the tower. The input is sorted by Xi value in ascending order and no two buildings have the same X value.

Output

For each test case, output one line containing the minimum number of swings (if it's possible to reach the tower) or -1 if Spiderman can't reach the tower.

Sample Input

2
6
0 3
3 5
4 3
5 5
7 4
10 4
3
0 3
3 4
10 4

Sample Output

3
-1

Source

提示

题意:

八爪章鱼博士绑架了蜘蛛侠的女票,蜘蛛侠需要火速赶到女票的所在地——West Tower。蜘蛛侠利用他的网粘着n(2<=n<=5000)个建筑物的顶端,以荡秋千的方式赶去,蜘蛛侠荡向另一边时,所到的位置必须与蜘蛛侠的公寓同高。

思路:

因为题目的特殊性,摇摆的距离对于建筑物本身是对称的,我们可以先预处理一下每个建筑物所能覆盖的距离,利用当前x轴位置j递推,dp[j]=min(dp[j],dp[i]+1),位置i为未经过当前建筑物摇摆时,所到该位置所需摇摆的次数。

示例程序

Source Code

Problem: 1925		Code Length: 1239B
Memory: 4420K		Time: 594MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <math.h>
struct
{
    long long x,y,dis;			//要注意用long long,否则会爆int
}build[5000];
int dp[1000001];
int main()
{
    int k,n,i,i1,i2;
    long long l,r,t;
    scanf("%d",&k);
    for(i=1;k>=i;i++)
    {
        scanf("%d",&n);
        for(i1=0;n>i1;i1++)
        {
            scanf("%lld %lld",&build[i1].x,&build[i1].y);
            build[i1].dis=sqrt(build[i1].y*build[i1].y-(build[i1].y-build[0].y)*(build[i1].y-build[0].y));
        }
        for(i1=0;build[n-1].x>=i1;i1++)
        {
            dp[i1]=10000000;
        }
        dp[build[0].x]=0;
        for(i1=1;n>i1;i1++)
        {
            l=build[i1].x-build[i1].dis;
            r=build[i1].x;
            if(l<0)
            {
                l=0;
            }
            for(i2=l;r>i2;i2++)
            {
                t=build[i1].x*2-i2;
                if(t>=build[n-1].x)
                {
                    t=build[n-1].x;
                }
                if(dp[t]>dp[i2]+1)
                {
                    dp[t]=dp[i2]+1;
                }
            }
        }
        if(dp[build[n-1].x]==10000000)
        {
            printf("-1\n");
        }
        else
        {
            printf("%d\n",dp[build[n-1].x]);
        }
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值