HDU 5120 Intersection(圆的面积交)

42 篇文章 0 订阅
11 篇文章 0 订阅

题目大意:给你两个圆环,让你求出来圆环的面积交,需要用到圆的面积交,然后容斥一下,就可以得到圆环的面积交。画一下图就会很清晰。

Intersection

Time Limit: 4000/4000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 526    Accepted Submission(s): 226


Problem Description
Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know.


A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below.


Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.
 

Input
The first line contains only one integer T (T ≤ 10 5), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10).

Each of the following two lines contains two integers x i, y i (0 ≤ x i, y i ≤ 20) indicating the coordinates of the center of each ring.
 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places.
 

Sample Input
  
  
2 2 3 0 0 0 0 2 3 0 0 5 0
 

Sample Output
  
  
Case #1: 15.707963 Case #2: 2.250778
 

Source
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <math.h>
#include <time.h>
#include <stack>
#include <map>
#include <set>
#define eps 1e-8
///#define LL long long
#define LL __int64
#define INF 0x3f3f3f
#define PI acos(-1)
#define mod 1000000007


using namespace std;

struct Point
{
    double x, y;
};

double Distance(Point a, Point b)
{
    return sqrt(((a.x-b.x)*(a.x-b.x) + (a.y-b.y)*(a.y-b.y))*1.0);
}

double area_of_overlap(Point c1, double r1, Point c2, double r2)
{
    double a = Distance(c1, c2);
    double b = r1;
    double c = r2;
    if((a >= b+c)) return 0.0;
    if(a < abs(b-c))
    {
        double r = min(r1, r2);
        return PI*r*r;
    }
    double cta1 = acos((a*a+b*b-c*c)/2.0/(a*b)),
           cta2 = acos((a*a+c*c-b*b)/2.0/(a*c));
    double s1 = r1*r1*cta1
                -r1*r1*sin(cta1)*(a*a+b*b-c*c)/2/(a*b);
    double s2 = r2*r2*cta2
                -r2*r2*sin(cta2)*(a*a+c*c-b*b)/2/(a*c);
    return s1+s2;
}

int main()
{
    int T;
    int Case = 1;
    scanf("%d",&T);
    while(T--)
    {
        double r1, r2;
        Point a, b;
        scanf("%lf %lf",&r1, &r2);
        scanf("%lf %lf", &a.x, &a.y);
        scanf("%lf %lf", &b.x, &b.y);
        printf("Case #%d: ",Case++);
        if(a.x == b.x && a.y == b.y)
        {
            printf("%.6lf\n",PI*(r2*r2-r1*r1));
            continue;
        }

        double sum = 0;
        sum += area_of_overlap(a, r2, b, r2);
        sum -= area_of_overlap(a, r1, b, r2);
        sum -= area_of_overlap(a, r2, b, r1);
        sum += area_of_overlap(a, r1, b, r1);
        printf("%.6lf\n",sum);
    }
    return 0;
}
/*
5
1 4
0 0 0 6
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值