ACM2014亚洲区北京赛区1009 Intersection(数学几何)

Intersection

Time Limit: 4000/4000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
  
  
Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know.
A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below.
Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.
 

Input
  
  
The first line contains only one integer T (T ≤ 10 5), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10). Each of the following two lines contains two integers x i, y i (0 ≤ x i, y i ≤ 20) indicating the coordinates of the center of each ring.
 

Output
  
  
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places.
 

Sample Input
  
  
2 2 3 0 0 0 0 2 3 0 0 5 0
 

Sample Output
  
  
Case #1: 15.707963 Case #2: 2.250778
 ac代码
#include<stdio.h>
#include<math.h>
double fun(double x1,double y1,double r1,double x2,double y2,double r2)
{
	double s1,s2,p,q,h1,h2,rs,s;
	double pi=2*asin(1.0);
	rs=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
		if(rs>=r1+r2||!r1||!r2)//情况要考虑完全注
			s=0;
		else
			if(rs<=fabs(r1-r2))
			{
				if(r1>=r2)
					s=pi*r2*r2;
				else
					s=pi*r1*r1;
			}
			else
			{
				p=acos((rs*rs+r1*r1-r2*r2)/(2*rs*r1));
				q=acos((rs*rs+r2*r2-r1*r1)/(2*rs*r2));
				h1=p*r1*r1;
				h2=q*r2*r2;
				s1=r1*r1*cos(p)*sin(p);
				s2=r2*r2*cos(q)*sin(q);
				s=h1+h2-(s1+s2);
			}
			return s;
}
int main()
{
	double x1,x2,y1,y2,r1,r2;
	
	int t,c=0;
	scanf("%d",&t);
	while(t--)
	{
		
		double rs,s,p,q,h1,h2,s2,ans,max,min,s1,s3,s4;
		scanf("%lf%lf%lf%lf%lf%lf",&r1,&r2,&x1,&y1,&x2,&y2);
		s1=fun(x1,y1,r1,x2,y2,r1);
		s2=fun(x1,y1,r2,x2,y2,r2);
		s3=fun(x1,y1,r1,x2,y2,r2);
		ans=s1-2*s3+s2;
		printf("Case #%d: ",++c);
		printf("%.6lf\n",ans);
			
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值