poj 1258 Agri-Net

不多说了啊、、典型的最小生成树啊、、、

Agri-Net
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 33507 Accepted: 13416

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

prim算法
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#define N 510
#define oo 1 << 30

using namespace std;

int map[N][N], d[N], n;
bool v[N];

int prim()
{
    memset(v , false , sizeof(v));
    int sum = 0;
    for(int i = 0; i < n; i++) d[i] = map[0][i];
    d[0] = 0;
    v[0] = true;
    for(int i = 0; i < n-1; i++)
    {
        int x, m = oo;
        for(int y = 0; y < n; y++) if(!v[y] && d[y]<=m) m = d[x=y];
        sum += m;
        v[x] = true;
        for(int y = 0; y < n; y++) if(!v[y] && d[y] > map[x][y]) d[y] = map[x][y];
    }
    return sum;
}

int main()
{
    int t, i, j;
    while(~scanf("%d",&n))
    {
        for(i = 0; i < n; i++)
            for(j = 0; j < n; j++)
                scanf("%d",&map[i][j]);
        printf("%d\n",prim());
    }
    return 0;
}
克鲁斯克尔算法
#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

struct Edge
{
    int u, v, w;
} edge[11000];
bool cmp(Edge a, Edge b)
{
    return a.w < b.w;
}
int mark[101000], t, sum;

int find(int x)
{
    while(x != mark[x])
        x = mark[x];
    return x;
}
void merge()
{
    sum = 0;
    int fu, fv;
    for(int i = 0; i < t; i++)
    {
        fu = find(edge[i].u);
        fv = find(edge[i].v);
        if(fu != fv)
        {
            mark[fu] = fv;
            sum += edge[i].w;
        }
    }
}
int main()
{
    int i, j, n;
    while(~scanf("%d",&n))
    {
        t = 0;
        for(i = 0; i <= n; i++) mark[i] = i;
        for(i = 1; i <= n; i++)
            for(j = 1; j <= n; j++)
            {
                scanf("%d",&edge[t].w);
                edge[t].u = i;
                edge[t++].v = j;
            }
        sort(edge , edge+t, cmp);
        merge();
        printf("%d\n",sum);
    }
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值