poj 3687 Labeling Balls


如图所示如果按照正序建图的话,先是输出1,然后2 的度更新为0,所以2在输出,就与题意不符合了啊,因为1,5的优先级相同,而2,5不同如果顺序建立的话,那就把顺序弄错了啊,所以逆序建图,从大到小遍历,如图先是遍历3,接着是4,2,5,1,然后把数组逆序输出就是答案了啊、、因为题目中要求是优先级相同的情况下输出序号小的。

Labeling Balls
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9180 Accepted: 2493

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4
#include <stdio.h>
#include <string.h>
#include <iostream>
#define N 500

using namespace std;

int map[N][N], in[N], v[N], re[N];
int n,m;

void _scanf()
{
    memset(map , 0 , sizeof(map));
    memset(in , 0 , sizeof(in));
    int a, b;
    scanf("%d %d",&n, &m);
    for(int i = 0; i < m; i++)
    {
        scanf("%d %d",&a, &b);
        a--;
        b--;
        if(!map[b][a])
        {
            in[a]++;
            map[b][a] = 1;
        }
    }
}

void topsort()
{
    for(int i = n; i > 0; i--)
    {
        int q = -1;
        for(int j = n-1; j >= 0; j--)
            if(in[j] == 0)
            {
                q = j;
                in[j]--;
                break;
            }
        if(q == -1)
        {
            printf("-1\n");
            return ;
        }
        re[q] = i;
        for(int j = 0; j < n; j++)
            if(map[q][j] == 1)
                in[j]--;
    }
    for(int i = 0; i < n-1; i++)
        printf("%d ",re[i]);
    printf("%d\n",re[n-1]);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        _scanf();
        topsort();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值