POJ 3687 Labeling Balls

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

思路:这道题是部分的拓扑排序。如果a->b,那要存图s[b].push_back(a),这样方便后面的排序。要先把不参与拓扑排序的部分先插入队列,然后在搜索队列里参与拓扑排序的根节点,依次进行拓扑排序(此时是s[b].push_back(a)),再把所有结果存入vector的时候,就是最终答案的倒序。
注意*
先得到编号的序列2 4 3 5 1,再与5 4 3 2 1一一对应,得到ans[2] = 5, ans[4] = 4, ans[3] = 3, ans[5] = 2, ans[1] = 1 从而找到输出答案1 5 3 4 2
#include <cstdio>
#include <iostream>
#include <string>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <vector>
#include <map>
using namespace std;

vector<int>s[40000+8];
vector<int>ans;
priority_queue<int>you;

int t, n, m, in[40000+8], en[200+8];

bool topo()
{
    while(!you.empty())
    {
        int f = you.top();
        you.pop();
        ans.push_back(f);//把答案倒序存入vector中
        for(int i = 0; i<s[f].size(); i++)//如果这个点连接着其他的点,也就是有拓扑排序,就对其进行操作
        {
            in[s[f][i]]--;
            if(!in[s[f][i]])
                you.push(s[f][i]);
        }
    }
    if(ans.size() == n)return true;
    else return false;
}

int main()
{
    int a, b;
    for(scanf("%d", &t); t--;)
    {
        memset(in, 0, sizeof(in));
        scanf("%d%d", &n, &m);
        for(int i = 0; i <= n; i++)s[i].clear();
        ans.clear();
        for(int i = 0; i<m; i++)
        {
            scanf("%d%d", &a, &b);
            s[b].push_back(a);
            in[a]++;
        }
        for(int i = 1; i <= n; i++)
            if(!in[i])
                you.push(i);//把单独的点和根节点都存入队列中
        if(topo())
        {
            for(int i = 0, j = n; i<ans.size(); i++, j--)
            {
                en[ans[i]] = j;//先得到编号的序列2 4 3 5 1,再与5 4 3 2 1一一对应,得到ans[2] = 5, ans[4] = 4, ans[3] = 3, ans[5] = 2, ans[1] = 1
            }
            bool flag = 0;
            for(int i = 1; i <= n; i++)//输出
            {
                if(flag)
                    printf(" ");
                flag = 1;
                printf("%d", en[i]);
            }
            printf("\n");
        }
        else printf("-1\n");
    }
    return 0;
}

 

 
 

转载于:https://www.cnblogs.com/RootVount/p/11213882.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值