acm_problem_1001 1008

问题描述:

Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
  
  
2 1 3

题目大意:大概就是输入木棒的长度和宽度,输入n个,处理木棒的时间为T,如果一个木棒的长度和宽度都不小于前一个木棒,那么时间不变,否则再加T。。

想法:可以根据宽度排序,宽度相等则再根据长度,如果后一个的L和W都不小于前一个的,就把前一个置0;继续这样做,两个for循环即可。。
 
代码:

#include <iostream>

#include <algorithm>
using namespace std;
struct stick
{
    int l;
    int w;
}s[10001];
bool cmp(stick c,stick d)
{
    if(c.w==d.w)
        return c.l<d.l;
    else
        return c.w<d.w;
}
int main()
{
    //freopen("r.txt","r",stdin);
    int i,m,n,o,j;
    while(cin>>m)
    {
        while(cin>>n&&m!=0)
        {
            for(j=1;j<=n;j++)
            {
                cin>>s[j].l>>s[j].w;
            }
            sort(s+1,s+n+1,cmp);
            int sum=0;
            for(j=1;j<=n;j++)
            {
                if(s[j].l!=0)
                {
                    sum++;
                    int f=s[j].l;
                    for(o=j+1;o<=n;o++)
                    {
                        if(s[o].l>=f)
                        {
                            f=s[o].l;
                            s[o].l=0;
                        }
                    }
                }
            }
            cout<<sum<<endl;
            m=m-1;
        }
    }

}


感想:OJ上两个题是一样的,但第一个提交成功,第二个却提交失败,后来实在改不出来了,让别人看了一下,去掉了cmp参数的取地址符,bool cmp(stick &c,stick &d)

就这里。。就提交成功了。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值